Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It might be just a basic thing for many, but I'm stuck at "Qt version control", and it's really annoying me. I'm on Ubuntu 12.04 LTS and my Qt version is 2.4.1.

Here's the message which is displayed:

No valid Qt versions found.
Please add a Qt version in Tools/Options or via the maintenance tool of the SDK.

snap01

I've installed bazaar (bzr) disabled all other version control plugins except bazaar but still can't get past the problem. Please guide me if I have to learn more about configuring with bazaar version control. snap03

I've added the qmake path too. snap02

I even tried disabling all the version control plugins but that too didn't go as I expected. I am (or maybe I should use was) thinking of learning to develop/code with Qt but haven't managed to get past creating a new project structure!

Please guide me through this.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Version Control System (VCS), Revision Control or Source Control are software systems used to track changes in files, usually used in software development.

How it works

Usually the files are hosted in a repository (a directory tree for each project). A developer A writes a software system and uses VCS to track the file changes. A developer B wants to add a new feature to the software system or fix a found bug. A common development process goes like this:

  • Developer B will want to get the sources in order to work on them
  • Developer B works on new features on his copy of the repository
  • Developer B commits his work locally
  • Developer B completes his job and commits the changes back to the remote (original) repository

Note this is one way of doing things, there can be various ways such as:

  • Working a one man project (solo) and keeping the repositories locally.
  • Working in a group project with a central remote repository
  • Various other flavors

For Bazaar you can check the documentation here and decide what works for you.

Do I Have Bazzar in my System?

You can check if Bazaar is installed in your system by issuing the following in terminal which bzr, if Bazaar is installed you will get: /usr/bin/bzr else you will have to install it with sudo apt-get install bzr

Potential Suspect

From the screenshots you provided it seems that you do not have QT development framework installed in your system (qmake is absent). You can get the Qt framework from the official site or through the Software Center (search for qt-sdk), it will yield the following: enter image description here

or sudo apt-get install qt-sdk, additionally you can install the documentation.

share|improve this answer
    
like you said some stuff were missing in my install, and installing the entire sdk fixed it.. thank you for your help. –  rusty May 1 at 3:10

First make sure that you have build-essential properly installed:

sudo apt-get install build-essential

Then in Tools -> Options -> Tool Chains just add GCC and set your gcc path as the compiler path.

UPDATE:

This my SDK setup on precise:

enter image description here

I seems that you need to specify qmake-qt4 instead of just qmake.

share|improve this answer
    
build-essential's installed, and I've added gcc and gdb manually alongside the auto-detected g++ and gdb in the tool chains.. problem still persist.. –  rusty Apr 30 at 10:08
    
I've updated my answer after testing the SDK on my 12.04 system –  Sylvain Pineau Apr 30 at 14:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.