Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have openvpn config files for tunnelbrick for Mac laptop, now I would like to import these files for Ubuntu 14.04. I know there is an open bug to import openvpn config file using network manager:

https://bugs.launchpad.net/ubuntu/+source/network-manager-openvpn/+bug/1294899

So I tried to use command line:

~/openvpn$ sudo openvpn --config config.ovpn

And the result:

Enter Auth Username:cuong
Enter Auth Password:
Wed Apr 30 14:21:12 2014 WARNING: file 'client-tls.key' is group or others accessible
Wed Apr 30 14:21:12 2014 Control Channel Authentication: using 'client-tls.key' as a      OpenVPN static key file
Wed Apr 30 14:21:12 2014 UDPv4 link remote: [AF_INET]113.161.74.10:1195
Wed Apr 30 14:21:12 2014 WARNING: this configuration may cache passwords in memory --  use the auth-nocache option to prevent this
Wed Apr 30 14:21:14 2014 [vpn.webonyx.com.vn] Peer Connection Initiated with [AF_INET]113.161.74.10:1195
Wed Apr 30 14:21:16 2014 TUN/TAP device tun0 opened
Wed Apr 30 14:21:16 2014 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
Wed Apr 30 14:21:16 2014 /sbin/ip link set dev tun0 up mtu 1500
Wed Apr 30 14:21:16 2014 /sbin/ip addr add dev tun0 local 10.0.10.18 peer 10.0.10.17
Wed Apr 30 14:21:16 2014 Initialization Sequence Completed

And the command line stops at 'Initialization Sequence Completed', but I cannot access to the VPN. My config file:

dev tun
persist-tun
persist-key
cipher AES-128-CBC
tls-client
client
resolv-retry infinite
remote vpn.webonyx.com.vn 1195 udp
tls-remote vpn.webonyx.com.vn
auth-user-pass
ca ca.crt
cert cuong.crt
key cuong.key
tls-auth client-tls.key 1
comp-lzo

Is there any way to work around this?

share|improve this question
    
Your connection is successful. However, not all routes are added. The server should normally push them. You can try adding redirect-gateway to your config. –  Louis Matthijssen Apr 30 at 8:21
    
@LouisMatthijssen: I tried to put redirect-gateway into the config file, but it's still not working, thanks –  Cuong Le Apr 30 at 11:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.