Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I click to close the XChat window, it asks whether to "Quit", "Cancel" or "Minimize to Tray". If I select "Minimize to tray" then the XChat disappears and I am not able to see the application again.

I have checked the process list and it is there in running state. Normally in earlier versions of Ubuntu it would show a XChat icon in the top panel bar.

I have not added the Xchat as sticky icon in my application panel. I hope there must be some work around or setting for it.

share|improve this question

1 Answer 1

I see three solutions:

  1. Disable the tray icon:

    • Settings → Preferences
    • Chatting → Alerts
    • Uncheck the Enable system tray icon checkbox.

    Now everytime you click on 'x' window button the application will quit. If you want to minimize it, just minimize it.

  2. Allow the tray icon to show. To do this, follow this answer and add 'Xchat' and 'xchat' to that whitelist:

    enter image description here

    (You need to install the package dconf-tools for the program dconf-editor.)

  3. Another alternative is to integrate XChat in the messages indicator by installing the xchat-indicator if you are using plain XChat, or xchat-gnome-indicator if you are using XChat GNOME. If you close the XChat window, you'll get it back via the XChat item in the messages menu:

    enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.