Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I have a bit of a problem. I started a PXE cluster of ubuntu zorin using vmlinuz-3.13-24. My server is running ubuntu server 14.04 which runs my TFTP and NFS Servers. I have a Microtik Router that I am using as my DHCP Server and to send the location and file of the TFTP server.

Everything boots up fine, I can even boot up multiple computers from the same file. But I do not have internet access. I am connected to the network, I can access the server, router, network drives, but no internet. I have tried to manually set it up but it still doesn't connect. If I click on the not connected icon it doesnt give me an ethernet network attached, and it says not managed. Is there a special internet server I must use for PXE?

ifconfig shows :

eth0      Link encap:Ethernet  HWaddr 08:00:27:13:57:1c  
      inet addr:192.168.0.64  Bcast:192.168.0.255  Mask:255.255.255.0
      inet6 addr: fe80::a00:27ff:fe13:571c/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:473410 errors:0 dropped:3 overruns:0 frame:0
      TX packets:135364 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:577914851 (577.9 MB)  TX bytes:22233809 (22.2 MB)

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:16 errors:0 dropped:0 overruns:0 frame:0
      TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:1184 (1.1 KB)  TX bytes:1184 (1.1 KB)`

Which matches the Routers lease address.

Network Manager shows:

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

I tried setting managed to true but that ended up breaking my PXE connection. And then it would just hang when it tried to boot.

etc/network/interfaces shows

 # interfaces(5) file used by ifup(8) and ifdown(8)
    auto lo
    iface lo inet loopback
    iface eth0 inet manual

route -n pulls up

 Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 eth0
    192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0

nslookup google.com pulled up timed out.

Im pretty new to ubuntu and networking in general, sooo im completely lost. Any help would be MUCH appreciated.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.