Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded vlc source vlc-2.0.6.tar.xz from sourceforge.

While compiling by ./configure, It gives following error:

configure: error: Could not find libmad on your system: you may get it from http://www.underbit.com/products/mad/. Alternatively you can use --disable-mad to disable the mad plugin.

After retrying ./configure ----disable-mad further errors:

No package 'libavutil' found. Pass --disable-avcodec to ignore this error.

And so on. How to solve this? Should I disable continuously with --disable ?

How solve such configure error. This question is not limited to vlc but widely I going to install package from source.

share|improve this question
up vote 1 down vote accepted

I suggest you following commands to solve this problem.

apt-get build-dep vlc
./configure

Ubuntu repository has also vlc.

So you can build it with following command.

apt-get source vlc
cd vlc-<version>
dpkg-buildpackage

Use dpkg-buildpackage -uc -us -b to get binaries, dpkg-buildpackage -uc -us -S for a source package without using sudo.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.