Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried to install Pantheon desktop environment several times. I tried sudo apt-get update and sudo apt-get upgrade, but it's no use. I’m just a very new beginner. This is what I’ve done:

quanglong@ubuntu:~$ sudo add-apt-repository ppa:elementary-os/daily
[sudo] password for quanglong: 
You are about to add the following PPA to your system:
 ATTENTION!
Do NOT install this PPA if you want a tested running system, this PPA contains the newest and most unstable development of elementary, it's useful only if you are a developer and are not afraid to encounter CRITICAL BUGS.
Also this PPA may overwrite already installed packages you don't want it to!
 More info: https://launchpad.net/~elementary-os/+archive/daily
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmpkz5d_z/secring.gpg' created
gpg: keyring `/tmp/tmpkz5d_z/pubring.gpg' created
gpg: requesting key 4E1F8A59 from hkp server keyserver.ubuntu.com
gpg: /tmp/tmpkz5d_z/trustdb.gpg: trustdb created
gpg: key 4E1F8A59: public key "Launchpad PPA for elementary OS team" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK
/bin/rm: cannot remove `/run/user/root/gvfs': Is a directory
quanglong@ubuntu:~$ sudo apt-get update
Hit http://ppa.launchpad.net quantal Release.gpg                               
Get:1 http://security.ubuntu.com quantal-security Release.gpg [933 B]          
Hit http://us.archive.ubuntu.com quantal Release.gpg                           
Hit http://ppa.launchpad.net quantal Release.gpg
Get:2 http://security.ubuntu.com quantal-security Release [49.6 kB]
Get:3 http://us.archive.ubuntu.com quantal-updates Release.gpg [933 B]       
Hit http://us.archive.ubuntu.com quantal-backports Release.gpg                 
Hit http://ppa.launchpad.net quantal Release             
Hit http://us.archive.ubuntu.com quantal Release                               
Hit http://ppa.launchpad.net quantal Release                                   
Get:4 http://us.archive.ubuntu.com quantal-updates Release [49.6 kB]           
Hit http://ppa.launchpad.net quantal/main Sources                             
Get:5 http://security.ubuntu.com quantal-security/main Sources [74.3 kB]      
Hit http://ppa.launchpad.net quantal/main amd64 Packages                       
Hit http://ppa.launchpad.net quantal/main i386 Packages                        
Hit http://us.archive.ubuntu.com quantal-backports Release                     
Hit http://us.archive.ubuntu.com quantal/main Sources                          
Hit http://us.archive.ubuntu.com quantal/restricted Sources                    
Hit http://us.archive.ubuntu.com quantal/universe Sources
Hit http://ppa.launchpad.net quantal/main Sources                              
Hit http://us.archive.ubuntu.com quantal/multiverse Sources           
Get:6 http://security.ubuntu.com quantal-security/restricted Sources [1,833 B]
Hit http://us.archive.ubuntu.com quantal/main amd64 Packages                   
Hit http://ppa.launchpad.net quantal/main amd64 Packages              
Hit http://us.archive.ubuntu.com quantal/restricted amd64 Packages
Get:7 http://security.ubuntu.com quantal-security/universe Sources [23.8 kB]
Hit http://ppa.launchpad.net quantal/main i386 Packages                       
Hit http://us.archive.ubuntu.com quantal/universe amd64 Packages              
Hit http://us.archive.ubuntu.com quantal/multiverse amd64 Packages             
Get:8 http://security.ubuntu.com quantal-security/multiverse Sources [1,169 B]
Hit http://us.archive.ubuntu.com quantal/main i386 Packages                    
Hit http://us.archive.ubuntu.com quantal/restricted i386 Packages     
Get:9 http://security.ubuntu.com quantal-security/main amd64 Packages [207 kB]
Hit http://us.archive.ubuntu.com quantal/universe i386 Packages               
Hit http://us.archive.ubuntu.com quantal/multiverse i386 Packages              
Hit http://us.archive.ubuntu.com quantal/main Translation-en                   
Hit http://us.archive.ubuntu.com quantal/multiverse Translation-en             
Hit http://us.archive.ubuntu.com quantal/restricted Translation-en             
Hit http://us.archive.ubuntu.com quantal/universe Translation-en               
Get:10 http://us.archive.ubuntu.com quantal-updates/main Sources [134 kB]      
Get:11 http://security.ubuntu.com quantal-security/restricted amd64 Packages [3,469 B]
Get:12 http://security.ubuntu.com quantal-security/universe amd64 Packages [72.4 kB]
Ign http://ppa.launchpad.net quantal/main Translation-en_US                    
Get:13 http://us.archive.ubuntu.com quantal-updates/restricted Sources [2,564 B]
Ign http://ppa.launchpad.net quantal/main Translation-en                       
Get:14 http://us.archive.ubuntu.com quantal-updates/universe Sources [96.7 kB] 
Ign http://ppa.launchpad.net quantal/main Translation-en_US                    
Get:15 http://security.ubuntu.com quantal-security/multiverse amd64 Packages [1,488 B]
Ign http://ppa.launchpad.net quantal/main Translation-en                       
Get:16 http://security.ubuntu.com quantal-security/main i386 Packages [205 kB] 
Get:17 http://us.archive.ubuntu.com quantal-updates/multiverse Sources [5,269 B]
Get:18 http://us.archive.ubuntu.com quantal-updates/main amd64 Packages [337 kB]
Get:19 http://us.archive.ubuntu.com quantal-updates/restricted amd64 Packages [4,804 B]
Get:20 http://us.archive.ubuntu.com quantal-updates/universe amd64 Packages [218 kB]
Get:21 http://security.ubuntu.com quantal-security/restricted i386 Packages [3,531 B]
Get:22 http://security.ubuntu.com quantal-security/universe i386 Packages [73.0 kB]
Get:23 http://us.archive.ubuntu.com quantal-updates/multiverse amd64 Packages [12.1 kB]
Get:24 http://security.ubuntu.com quantal-security/multiverse i386 Packages [1,726 B]
Hit http://security.ubuntu.com quantal-security/main Translation-en            
Get:25 http://us.archive.ubuntu.com quantal-updates/main i386 Packages [334 kB]
Hit http://security.ubuntu.com quantal-security/multiverse Translation-en      
Hit http://security.ubuntu.com quantal-security/restricted Translation-en      
Hit http://security.ubuntu.com quantal-security/universe Translation-en        
Get:26 http://us.archive.ubuntu.com quantal-updates/restricted i386 Packages [4,841 B]
Get:27 http://us.archive.ubuntu.com quantal-updates/universe i386 Packages [219 kB]
Get:28 http://us.archive.ubuntu.com quantal-updates/multiverse i386 Packages [12.3 kB]
Hit http://us.archive.ubuntu.com quantal-updates/main Translation-en           
Hit http://us.archive.ubuntu.com quantal-updates/multiverse Translation-en     
Hit http://us.archive.ubuntu.com quantal-updates/restricted Translation-en     
Hit http://us.archive.ubuntu.com quantal-updates/universe Translation-en       
Hit http://us.archive.ubuntu.com quantal-backports/main Sources                
Hit http://us.archive.ubuntu.com quantal-backports/restricted Sources          
Ign http://security.ubuntu.com quantal-security/main Translation-en_US         
Hit http://us.archive.ubuntu.com quantal-backports/universe Sources            
Ign http://security.ubuntu.com quantal-security/multiverse Translation-en_US   
Hit http://us.archive.ubuntu.com quantal-backports/multiverse Sources          
Ign http://security.ubuntu.com quantal-security/restricted Translation-en_US   
Hit http://us.archive.ubuntu.com quantal-backports/main amd64 Packages         
Ign http://security.ubuntu.com quantal-security/universe Translation-en_US     
Hit http://us.archive.ubuntu.com quantal-backports/restricted amd64 Packages   
Hit http://us.archive.ubuntu.com quantal-backports/universe amd64 Packages     
Hit http://us.archive.ubuntu.com quantal-backports/multiverse amd64 Packages   
Hit http://us.archive.ubuntu.com quantal-backports/main i386 Packages          
Hit http://us.archive.ubuntu.com quantal-backports/restricted i386 Packages    
Hit http://us.archive.ubuntu.com quantal-backports/universe i386 Packages      
Hit http://us.archive.ubuntu.com quantal-backports/multiverse i386 Packages    
Hit http://us.archive.ubuntu.com quantal-backports/main Translation-en         
Hit http://us.archive.ubuntu.com quantal-backports/multiverse Translation-en   
Hit http://us.archive.ubuntu.com quantal-backports/restricted Translation-en   
Hit http://us.archive.ubuntu.com quantal-backports/universe Translation-en     
Ign http://us.archive.ubuntu.com quantal/main Translation-en_US                
Ign http://us.archive.ubuntu.com quantal/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com quantal/restricted Translation-en_US
Ign http://us.archive.ubuntu.com quantal/universe Translation-en_US
Ign http://us.archive.ubuntu.com quantal-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com quantal-updates/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com quantal-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com quantal-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com quantal-backports/main Translation-en_US
Ign http://us.archive.ubuntu.com quantal-backports/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com quantal-backports/restricted Translation-en_US
Ign http://us.archive.ubuntu.com quantal-backports/universe Translation-en_US
Fetched 2,151 kB in 45s (47.7 kB/s)
Reading package lists... Done
/bin/rm: cannot remove `/run/user/root/gvfs': Is a directory
quanglong@ubuntu:~$ sudo apt-get install elementary-desktop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package elementary-desktop
/bin/rm: cannot remove `/run/user/root/gvfs': Is a directory
quanglong@ubuntu:~$ 
share|improve this question
    
post the output of cat ~/.bashrc in your question. –  Avinash Raj Apr 29 at 13:18

2 Answers 2

A quick look shows that there isn't a elementary-desktop in the PPA. Have a look at these instructions.

share|improve this answer
    
Disclaimer: I have not personally tried these instructions. –  arty Apr 29 at 13:14
    
thank you, butbut it doesn't help –  user275846 Apr 29 at 13:33
    
Are you following a set of instructions? –  arty Apr 29 at 20:19
    
Yes. I have followed it but the error still apeared –  user275846 Apr 30 at 5:07

Okay I got build errors. Haven't got time to test it at the moment :(.

Also: "After this operation, 1779 MB of additional disk space will be used." So make sure you have a few GB's set aside if you're going to do this.


Okay so I got it working by following this: How to install the Pantheon desktop environment? Basically the PPA everyone is suggesting works, is 404-ing for me (and presumably you) when I try and access it.

1) This is syslinux-themes-elementary-isis, and the .sh script apparently requires it. Sudo apt-get didn't find it for me. You could probably test removing this dependency from the .sh if you are feeling bold. I installed amd64 version of this (as I am on 64 bit, if you are on 32 bit obviously don't), just use a .deb installer on Ubuntu:

https://launchpad.net/~elementary-os/+archive/daily/+files/syslinux-themes-elementary-isis_2-0%7E4%7Esaucy1_amd64.deb

2) This is required by the elementary os install script:

sudo apt-get install dctrl-tools dpkg-dev 
    genisoimage gfxboot-theme-ubuntu live-build squashfs-tools syslinux zsync

3) The script uses this to determine what files to download (obviously don't do both, amd64 is for 64bit and i386 is for 32 bit) (you'll want to put this in .bashrc or somewhere else for it to be permanent, not 100% anyone will ever need this again though):

export ARCH=amd64
export ARCH=i386

4) From the previous question/answer thread:

sudo apt-get install bzr
bzr branch lp:elementaryos
cd elementaryos
sudo congrego.sh

On my machine I didn't specify $ARCH so I got 90% of the way through a 970 M .iso file for i386 before I realised -_-.

Currently running through the amd64 installation.


As an aside:

# load config
source etc/congrego.conf

if [[ "$ARCH" == "all" ]]; then
        $(dirname "$0")/bin/download.sh i386
        $(dirname "$0")/bin/download.sh amd64
        $(dirname "$0")/bin/build.sh i386
        $(dirname "$0")/bin/build.sh amd64
        if [[ "$SOURCEFORGE" != "" ]]; then
            $(dirname "$0")/bin/sourceforge.sh i386
            $(dirname "$0")/bin/sourceforge.sh amd64
        fi
else
        $(dirname "$0")/bin/download.sh "$ARCH"
        $(dirname "$0")/bin/build.sh "$ARCH"
        $(dirname "$0")/bin/sourceforge.sh "$ARCH"
fi

It is a bit presumptuous that users would have that environment variable set. Unless I am reading it wrong, it seems like it will download iso's for i386 AND amd64 and then build both of them, which sounds like a bad idea. I'm noob at bash script though so it could be fine for all I know.

Just in case this is irrelevant to your machine:

Linux mikeydesknix 3.11.0-19-generic #33-Ubuntu SMP Tue Mar 11 18:48:34 UTC 2014 
x86_64 x86_64 x86_64 GNU/Linux

[ mikey ][ 02:22:59 ]$lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 13.10
Release:    13.10
Codename:   saucy

--

Build Errors:

[2014-05-01 03:31:40] lb_chroot_hooks 
P: Begin executing hooks...
ERROR:root:DebFileApplication import
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/db/__init__.py", line 4, in <module>
    from debfile import DebFileApplication, DebFileOpenError
  File "/usr/share/software-center/softwarecenter/db/debfile.py", line 25, in <module>
    from softwarecenter.db.application import Application, AppDetails
  File "/usr/share/software-center/softwarecenter/db/application.py", line 28, in <module>
    import softwarecenter.distro
  File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 199, in <module>
    distro_instance = _get_distro()
  File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 174, in _get_distro
    module = __import__(distro_module_name, globals(), locals(), [], -1)
ImportError: No module named "elementary os"
Traceback (most recent call last):
  File "/usr/sbin/update-apt-xapian-index", line 101, in <module>
    if not indexer.setupIndexing(force=opts.force, system=opts.pkgfile is None):
  File "/usr/lib/python2.7/dist-packages/axi/indexer.py", line 471, in setupIndexing
    self.plugins = Plugins(progress=self.progress, system=system)
  File "/usr/lib/python2.7/dist-packages/axi/indexer.py", line 94, in __init__
    addon = Addon(fullname, **kw)
  File "/usr/lib/python2.7/dist-packages/axi/indexer.py", line 49, in __init__
    self.module = imp.load_source("axi.plugin_" + self.name, fname)
  File "/usr/share/apt-xapian-index/plugins/software_center.py", line 13, in <module>
    from softwarecenter.db.update import (
  File "/usr/share/software-center/softwarecenter/db/update.py", line 33, in <module>
    from softwarecenter.backend.scagent import SoftwareCenterAgent
  File "/usr/share/software-center/softwarecenter/backend/scagent.py", line 28, in <module>
    from softwarecenter.distro import get_distro, get_current_arch
  File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 199, in <module>
    distro_instance = _get_distro()
  File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 174, in _get_distro
    module = __import__(distro_module_name, globals(), locals(), [], -1)
ImportError: No module named "elementary os"
E: chroot/root/lb_chroot_hooks/002-update-apt-xapian-index.chroot failed (exit non-zero). You should check for errors.
P: Begin unmounting filesystems...
P: Saving caches...
Reading package lists...
Building dependency tree...
Reading state information...
md5sum: binary.hybrid.iso: No such file or directory
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.