Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried so many things, that I have no idea how to resolve this.

I want to update my packages on my server. For that I do the following:

sudo apt-get update
sudo apt-get upgrade

I then get the following response:

peter@blackbox:/etc/apt$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libavahi-common-data : Breaks: libavahi-common-data:i386 (!= 0.6.30-5ubuntu2) but 0.6.30-5ubuntu2.1 is installed
 libavahi-common-data:i386 : Breaks: libavahi-common-data (!= 0.6.30-5ubuntu2.1) but 0.6.30-5ubuntu2 is installed
E: Unmet dependencies. Try using -f.

Following the instructions:

peter@blackbox:/etc/apt$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libcommons-jxpath-java libplexus-archiver-java libmaven-plugin-tools-java libcdi-api-java libplexus-containers-java linux-headers-3.2.0-44-generic linux-headers-3.2.0-39-generic libwagon-java libmodello-java
  linux-image-3.2.0-55-generic libsisu-guice-java libplexus-classworlds-java libmaven2-core-java libjtidy-java linux-image-3.2.0-37-generic linux-headers-3.2.0-52-generic libhttpclient-java libaspectj-java libservlet2.4-java
  libplexus-velocity-java linux-headers-3.2.0-32 linux-headers-3.2.0-33 linux-headers-3.2.0-40 linux-headers-3.2.0-35 linux-headers-3.2.0-36 linux-headers-3.2.0-37 linux-headers-3.2.0-43 linux-headers-3.2.0-38 linux-headers-3.2.0-44
  linux-headers-3.2.0-39 linux-headers-3.2.0-45 linux-headers-3.2.0-51 linux-headers-3.2.0-52 linux-headers-3.2.0-53 linux-headers-3.2.0-48 linux-headers-3.2.0-55 libcommons-jexl-java linux-headers-3.2.0-56 libosgi-compendium-java
  libplexus-cipher-java libguava-java libplexus-classworlds2-java libplexus-build-api-java libplexus-i18n-java linux-image-3.2.0-45-generic libnetty-java linux-headers-3.2.0-55-generic libplexus-interactivity-api-java libqdox-java
  libgeronimo-jpa-2.0-spec-java linux-headers-3.2.0-37-generic libcglib-java linux-image-3.2.0-53-generic linux-image-3.2.0-48-generic libxbean-java libcommons-net2-java libsaxon-java libdoxia-sitetools-java glassfish-javaee
  libitext1-java linux-image-3.2.0-40-generic libcommons-collections-java linux-headers-3.2.0-45-generic linux-image-3.2.0-56-generic libosgi-foundation-ee-java libasync-http-client-java libplexus-ant-factory-java libplexus-cli-java
  libplexus-container-default-java aspectj linux-headers-3.2.0-32-generic libeasymock-java linux-image-3.2.0-43-generic linux-image-3.2.0-38-generic linux-headers-3.2.0-53-generic linux-headers-3.2.0-48-generic fop libaopalliance-java
  libgeronimo-interceptor-3.0-spec-java libplexus-io-java libplexus-bsh-factory-java libclassworlds-java libplexus-interpolation-java libosgi-core-java linux-headers-3.2.0-40-generic linux-headers-3.2.0-35-generic
  linux-image-3.2.0-51-generic linux-headers-3.2.0-56-generic libhttpcore-java libcommons-httpclient-java libplexus-containers1.5-java libcommons-vfs-java linux-headers-3.2.0-43-generic linux-headers-3.2.0-38-generic libslf4j-java
  libasm3-java libjsoup-java libfop-java libaether-java libatinject-jsr330-api-java libsisu-ioc-java libcommons-configuration-java libmaven-reporting-impl-java velocity libxmlgraphics-commons-java linux-headers-3.2.0-51-generic
  libwerken.xpath-java libgeronimo-osgi-support-java libnetbeans-cvsclient-java libplexus-utils-java linux-headers-3.2.0-33-generic libplexus-sec-dispatcher-java libcommons-validator-java linux-image-3.2.0-44-generic
  linux-image-3.2.0-39-generic libmaven-scm-java libdoxia-java libcommons-digester-java libbatik-java libjetty-java libcommons-io-java libplexus-utils2-java linux-headers-3.2.0-36-generic libganymed-ssh2-java
  linux-image-3.2.0-52-generic
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libavahi-common-data
The following packages will be upgraded:
  libavahi-common-data
1 upgraded, 0 newly installed, 0 to remove and 68 not upgraded.
8 not fully installed or removed.
Need to get 0 B/21.4 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? Y
dpkg: error processing libavahi-common-data (--configure):
 libavahi-common-data:amd64 0.6.30-5ubuntu2 cannot be configured because libavahi-common-data:i386 is in a different version (0.6.30-5ubuntu2.1)
dpkg: error processing libavahi-common-data:i386 (--configure):
 libavahi-common-data:i386 0.6.30-5ubuntu2.1 cannot be configured because libavahi-common-data:amd64 is in a different version (0.6.30-5ubuntu2)
dpkg: dependency problems prevent configuration of libavahi-common3:i386:
 libavahi-common3:i386 depends on libavahi-common-data; however:
  Package libavahi-common-data:i386 is not configured yet.
dpkg: error processing libavahi-common3:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libavahi-common3:
 libavahi-common3 depends on libavahi-common-data; however:
  Package libavahi-common-data is not configured yet.
dpkg: error processing libavahi-common3 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libavahi-client3:
 libavahi-client3 depends on libavahi-common3 (>= 0.6.22); however:
  Package libavahi-common3 is not configured yet.
dpkg: error processing libavahi-client3 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libavahi-client3:i386:
 libavahi-client3:i386 depends on libavahi-common3 (>= 0.6.22); No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                                                                                          No apport report written because the error message indicates its a followup error from a previous failure.
                                       No apport report written because MaxReports is reached already
                                                                                                     No apport report written because MaxReports is reached already
                                                                                                                                                                   however:
  Package libavahi-common3:i386 is not configured yet.
dpkg: error processing libavahi-client3:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libavahi-core7:
 libavahi-core7 depends on libavahi-common3 (>= 0.6.16); however:
  Package libavahi-common3 is not configured yet.
dpkg: error processing libavahi-core7 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of avahi-daemon:
 avahi-daemon depends on libavahi-common3 (>= 0.6.16); however:
  Package libavahi-common3 is not configured yet.
 avahi-daemon depends on libavahi-core7 (>= 0.6.24); however:
  Package libavahi-core7 is not configured yet.
dpkg: error processing avahi-daemon (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libavahi-common-data
 libavahi-common-data:i386
 libavahi-common3:i386
 libavahi-common3
 libavahi-client3
 libavahi-client3:i386
 libavahi-core7
 avahi-daemon
E: Sub-process /usr/bin/dpkg returned an error code (1)

Anyone has any idea how to resolve this?


Update 30-04-2014:

As Avinash Raj suggested I have hold back the libavahi-common-data and run his commands. I get the following:

peter@blackbox:~$ sudo apt-get autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libavahi-common-data : Breaks: libavahi-common-data:i386 (!= 0.6.30-5ubuntu2) but     0.6.30-5ubuntu2.1 is installed
 libavahi-common-data:i386 : Breaks: libavahi-common-data (!= 0.6.30-5ubuntu2.1) but 0.6.30-5ubuntu2 is installed
E: Unmet dependencies. Try using -f.

peter@blackbox:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 libavahi-common-data : Breaks: libavahi-common-data:i386 (!= 0.6.30-5ubuntu2) but 0.6.30-5ubuntu2.1 is installed
 libavahi-common-data:i386 : Breaks: libavahi-common-data (!= 0.6.30-5ubuntu2.1) but 0.6.30-5ubuntu2 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
share|improve this question
    
possible duplicate of How do I resolve unmet dependencies? –  i08in Apr 29 at 8:19
1  
Try to uninstall libavahi-common-data and everything that goes along with it, then installing it again. –  Jos Apr 29 at 9:54

1 Answer 1

Just simply hold the package libavahi-common-data to prevent it from upgrade, so that it won't appears in the packages need to upgraded list.

sudo apt-mark hold libavahi-common-data

Now run the below commands to remove all the unused packages and to fix the dependencies,

sudo apt-get autoremove
sudo apt-get install -f
share|improve this answer
    
I updated my question after trying your suggestion. –  Peerke Apr 30 at 11:49
    
post the output of sudo apt-mark showhold –  Avinash Raj Apr 30 at 12:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.