Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Optimus laptop, a Dell XPS 15 L502, which I've had for a few years and have tried various things on (bumblebee, nvidia-prime, linux kernel optimus support).

The graphics card is an NVIDIA GT 540M.

I upgraded to Ubuntu 14.04 a few days ago and wanted to try nvidia-prime again (it wasn't working so great for me on 13.10), but nvidia-settings only tells me that it is not supported.

Software and Updates recognises the Nvidia card and drivers. Nvidia Settings currently gives me this:

** Message: PRIME: No offloading required. Abort
** Message: PRIME: is it supported? no

I've tried to purge and reinstall nvidia drivers a dozen times, I've tried with and without xorg.conf files, but still always the same thing.

I've followed all the guides I could find on StackOverflow, AskUbuntu, and various other places.

I'm happy to provide parts of certain log files if needed. I haven't been able to glean much from them (though I'm not exactly an expert).

I would be glad if someone could give me any hints as to why this is not working for me while it does seem to work for so many others.

EDIT: I was having problem with booting into "low-graphics mode", but that was due to a bad lightdm configuration that broke when I upgraded. I also had some segmentation fault issues with nvidia-settings installing the wrong version of itself (this was fixed by reinstalling just nvidia-settings).

EDIT: Have also found this bug report: https://bugs.launchpad.net/ubuntu/+source/nvidia-prime/+bug/1283439

share|improve this question

2 Answers 2

up vote 9 down vote accepted

I have the same portable, I was using bumblebee before. But since 14.04 it was not working anymore and so now I switched to nvidia-prime. This is what I did:

Steps

  • Install Nouveau driver through "Software & updates"

  • Remove bumblebee or other installed nvidia drivers:

    sudo apt-get purge bumblebee*
    sudo apt-get purge nvidia-*
    
  • An then reboot

  • Install nvidia 331-updates driver through "Software & updates" (should also install nvidia-settings and nvidia-prime)

  • Then reboot

Now run again nvidia-settings. This did it for me, more info here.

share|improve this answer
1  
I've fixed some of my other issues (thanks for putting me on the right track, but I still get the "is it supported? no" error message. Maybe it is the graphics card version? I've updated the question with the details (GT 540M). –  dieuwe May 1 at 22:00
    
I did just get this "working", but ended up having to uninstall nvidia again due to the massive instability issues I am having with my displays. Not sure if the problem is caused by nvidia or not, but it seems the nvidia 331 package now supports my hardware. –  dieuwe Jun 7 at 9:40

I had a similar problem. This is just a note to whomever else might find it useful.

Things started working once I re-enabled optimus from BIOS.

It seems the developers didn't do enough error handling. There should really be a bug report about that.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.