Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install gcc on ubuntu using :

sudo apt-get install gcc

I get the following error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libaio-dev : Depends: libaio1 (= 0.3.107-7) but 0.3.109-2ubuntu1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I try sudo apt-get -f install

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libgmp10:i386 libmpfr4:i386 libgomp1:i386 libquadmath0:i386
  libtinfo-dev:i386 libc6-dev:i386 linux-libc-dev:i386 libmpc2:i386
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libaio-dev
The following packages will be upgraded:
  libaio-dev
1 upgraded, 0 newly installed, 0 to remove and 19 not upgraded.
1 not fully installed or removed.
Need to get 0 B/23.2 kB of archives.
After this operation, 80.9 kB disk space will be freed.
Do you want to continue [Y/n]? y
dpkg: dependency problems prevent configuration of libaio-dev:
 libaio-dev depends on libaio1 (= 0.3.107-7); however:
  Version of libaio1 on system is 0.3.109-2ubuntu1.
dpkg: error processing libaio-dev (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 libaio-dev
E: Sub-process /usr/bin/dpkg returned an error code (1)

Can someone please help?

Thanks

share|improve this question
    
Can you try sudo apt-get upgrade libaio-dev? –  saiarcot895 Apr 29 at 3:04
    
I tried that but i get the same error: libaio-dev : Depends: libaio1 (= 0.3.107-7) but 0.3.109-2ubuntu1 is installed You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: libaio-dev : Depends: libaio1 (= 0.3.107-7) but 0.3.109-2ubuntu1 is installed. sudo apt-get -f install also gives the same error: libaio-dev depends on libaio1 (= 0.3.107-7); however: Version of libaio1 on system is 0.3.109-2ubuntu1. –  srai Apr 29 at 4:22
    
Isn't gcc installed by default? Anyway, try sudo apt-get upgrade, then the sudo apt-get install gcc if is really isn't present. –  ubfan1 Apr 29 at 4:55
    
I already tried doing sudo apt-get upgrade. i get the same error message: The following packages have unmet dependencies: libaio-dev : Depends: libaio1 (= 0.3.107-7) but 0.3.109-2ubuntu1 is installed –  srai Apr 29 at 5:17
    
How can i completely remove 0.3.109-2ubuntu1 from my system? –  srai Apr 29 at 5:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.