Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I've just installed Natty in a laptop with a non-working back-light, so I have to use an external monitor in order to see anything. The problem is that the two nVidia proprietary drivers available won't recognize the external monitor.

When using the "classic" configuration or uninstalling the additional drivers Linux detects the monitor with no problems. On the other hand, the experimental driver detects the screen and works fine (effects and all) but I have flickering issues (they take the lower half of the screen, especially if I'm watching a video) like every hour, and some times they're very annoying. I'm thinking of either installing a previous version of Ubuntu and seeing how it works or staying with the default driver and no effects at all.

  • My video card: nVidia Geforce 8200M G (256mb)
  • Laptop model: Compaq cq50-204CA, 3gb ram
share|improve this question

marked as duplicate by Luis Alvarado Apr 20 '13 at 1:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 0 down vote accepted

I have this video card on my presario cq-60 laptop about 2 years. It is disaster.

  1. Use nvidia blob drive - nouveau has not power saving features for this card.
  2. Use vga to connect to external display instead hdmi or dvi - they works only in 17x.xx driver witch has a lot of troubles.
  3. When use external display - use only it. Do not setup twinview to use 2 displays together.
  4. In compiz settings (install ccsm) unselect "detect refresh rate" and set a "refresh rate" to 60.

For my opinion this is most suitable options for this graphic card.

In your situation the external display do not work with nvidia because nvidia uses internal display by default. To turn it on you should to do this steps:

Install nvidia driver 2. Reboot with live cd. 3. Find your linux partition in "My computer" and open it (in order to mount it). 4. Now open terminal and type "sudo nautilus" 5. In new window that will be opened by previous command go to your linux partition (you can see it on the left panel) and find etc/X11/xorg.conf 6. Open it for editing and append section "Device" with : option "TwinView" "True" 7. Save changes and reboot.

After that nvidia driver will use both displays and you can login and disable laptop display trough nvidia settings.

share|improve this answer
    
Thanks a lot for your help. I did this with Natty but the nvidia settings window didn't open at all so I was stuck with one desktop in each screen (which was really cumbersome since the login dialog and other important screens appeared on the non-working back-light one). Instead I installed ubuntu 10.04, did all the steps you provided, and it worked like charm. –  Daniel Jun 7 '11 at 5:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.