Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After updating from 13.10 to 14.04 my MP3 player is not mounted anymore. Under 13.10 it behaved like a normal USB stick and I could copy files to it. Since the upgrade the device does not show up as block device anymore.

After a fresh reboot the stick gets mounted for a few seconds, and then disappears.

I can see the player with

$ lsusb
Bus 002 Device 020: ID 054c:0689 Sony Corp.

and

$ udevadm monitor
KERNEL[3031.177130] add      /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6 (usb)
KERNEL[3031.177631] add      /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0 (usb)
KERNEL[3031.177769] add      /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/host34 (scsi)
KERNEL[3031.177788] add      /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/host34/scsi_host/host34 (scsi_host)
UDEV  [3031.190066] add      /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6 (usb)
UDEV  [3031.194110] add      /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0 (usb)
UDEV  [3031.195647] add      /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/host34 (scsi)
UDEV  [3031.196342] add      /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/host34/scsi_host/host34 (scsi_host)
KERNEL[3031.199824] remove   /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/host34/scsi_host/host34 (scsi_host)
KERNEL[3031.199946] remove   /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/host34 (scsi)
UDEV  [3031.200736] remove   /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/host34/scsi_host/host34 (scsi_host)
UDEV  [3031.200761] remove   /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/host34 (scsi)
KERNEL[3031.368640] add      /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/host35 (scsi)
KERNEL[3031.369862] add      /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/host35/scsi_host/host35 (scsi_host)
UDEV  [3031.369877] add      /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/host35 (scsi)
UDEV  [3031.369886] add      /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/host35/scsi_host/host35 (scsi_host)
KERNEL[3031.536654] remove   /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/host35/scsi_host/host35 (scsi_host)
KERNEL[3031.536680] remove   /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/host35 (scsi)
UDEV  [3031.537269] remove   /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/host35/scsi_host/host35 (scsi_host)
UDEV  [3031.537293] remove   /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/host35 (scsi)

and

$ tail -f /var/log/syslog
Apr 28 20:32:51 ubuntu colord: Device added: sysfs-SONY-WALKMAN
Apr 28 20:32:51 ubuntu colord: Device added: sysfs-(null)
Apr 28 20:32:51 ubuntu kernel: [ 3219.231831] usb 2-1.6: usbfs: process 3053 (ThreadWeaver::T) did not claim interface 0 before use
Apr 28 20:32:51 ubuntu kernel: [ 3219.302565] usb 2-1.6: reset high-speed USB device number 24 using ehci-pci
Apr 28 20:32:51 ubuntu kernel: [ 3219.394921] usb-storage 2-1.6:1.0: USB Mass Storage device detected
Apr 28 20:32:51 ubuntu kernel: [ 3219.394966] scsi37 : usb-storage 2-1.6:1.0
Apr 28 20:32:51 ubuntu kernel: [ 3219.395038] usb 2-1.6: usbfs: process 3053 (ThreadWeaver::T) did not claim interface 0 before use
Apr 28 20:32:51 ubuntu kernel: [ 3219.470571] usb 2-1.6: reset high-speed USB device number 24 using ehci-pci
Apr 28 20:32:51 ubuntu kernel: [ 3219.563279] usb 2-1.6: usbfs: process 3053 (ThreadWeaver::T) did not claim interface 0 before use
Apr 28 20:32:51 ubuntu kernel: [ 3219.634589] usb 2-1.6: reset high-speed USB device number 24 using ehci-pci
Apr 28 20:32:51 ubuntu kernel: [ 3219.727049] usb-storage 2-1.6:1.0: USB Mass Storage device detected
Apr 28 20:32:51 ubuntu kernel: [ 3219.727152] scsi38 : usb-storage 2-1.6:1.0
Apr 28 20:32:51 ubuntu kernel: [ 3219.727532] usb 2-1.6: usbfs: process 3038 (ThreadWeaver::T) did not claim interface 0 before use
Apr 28 20:32:52 ubuntu kernel: [ 3219.802645] usb 2-1.6: reset high-speed USB device number 24 using ehci-pci
Apr 28 20:32:52 ubuntu kernel: [ 3219.895293] usb 2-1.6: usbfs: process 3053 (ThreadWeaver::T) did not claim interface 0 before use

But with lsblk the device does not show up at all.

Any hints how I can fix or debug this?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Okay a bit more try and error and I found out that amarok was running in the background. When I quit amarok I could access the USB storage again.

Funny thing, but it took me a while to figure that out.

share|improve this answer
    
Disabling the MTP plugin in amarok solves my problems. Amarok is running and I can access the UBS storage on the player. –  Ruediger May 1 at 14:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.