Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm on Ubuntu 14.04. I've uninstalled Unity (simply because I can't stand it), and have installed Gnome

Now when I try to run an update, or even install other software I get an error and no updates or software gets installed.

It has to do with libreoffice and here is the error I am getting:

(Reading database ... 231635 files and directories currently installed.)
Preparing to unpack .../libreoffice-common_1%3a4.2.3~rc3-0ubuntu2_all.deb ...
Unpacking libreoffice-common (1:4.2.3~rc3-0ubuntu2) ...
dpkg: error processing archive /var/cache/apt/archives/libreoffice-common_1%3a4.2.3~rc3-0ubuntu2_all.deb (--unpack):
trying to overwrite '/usr/bin/soffice', which is also in package openoffice-debian-menus 4.0-9714
rmdir: failed to remove /var/lib/libreoffice/share/prereg/: No such file or directory
rmdir: failed to remove /var/lib/libreoffice/share/: No such file or directory
rmdir: failed to remove /var/lib/libreoffice/program/: No such file or directory
rmdir: failed to remove /var/lib/libreoffice: No such file or directory
rmdir: failed to remove /var/lib/libreoffice: No such file or directory
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for gnome-icon-theme (3.10.0-0ubuntu2) ...
Processing triggers for man-db (2.6.7.1-1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libreoffice-common_1%3a4.2.3~rc3-0ubuntu2_all.deb
Error in function: 
dpkg: dependency problems prevent configuration of libreoffice-core:

This happens in terminal as well as su.

What can I do to get this fixed? There is software that I need installed, and cannot do it because of this. Note: I do have OpenOffice installed...

Terminal Output

kevin@o7thDev:~$ sudo apt-get install -f
[sudo] password for kevin: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libreoffice-common
Suggested packages:
  libreoffice-style-crystal libreoffice-style-hicontrast
  libreoffice-style-oxygen libreoffice-style-sifr libreoffice-style-tango
The following NEW packages will be installed:
  libreoffice-common
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
14 not fully installed or removed.
Need to get 0 B/19.7 MB of archives.
After this operation, 75.8 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 231635 files and directories currently installed.)
Preparing to unpack .../libreoffice-common_1%3a4.2.3~rc3-0ubuntu2_all.deb ...
Unpacking libreoffice-common (1:4.2.3~rc3-0ubuntu2) ...
dpkg: error processing archive /var/cache/apt/archives/libreoffice-    common_1%3a4.2.3~rc3-0ubuntu2_all.deb (--unpack):
 trying to overwrite '/usr/bin/soffice', which is also in package openoffice-debian-    menus 4.0-9714
rmdir: failed to remove ‘/var/lib/libreoffice/share/prereg/’: No such file or directory
rmdir: failed to remove ‘/var/lib/libreoffice/share/’: No such file or directory
rmdir: failed to remove ‘/var/lib/libreoffice/program/’: No such file or directory
rmdir: failed to remove ‘/var/lib/libreoffice’: No such file or directory
rmdir: failed to remove ‘/var/lib/libreoffice’: No such file or directory
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for gnome-icon-theme (3.10.0-0ubuntu2) ...
Processing triggers for man-db (2.6.7.1-1) ...
E: Sub-process /usr/bin/dpkg returned an error code (1)
kevin@o7thDev:~$ 
share|improve this question
    
post the full output of sudo apt-get install -f –  Avinash Raj Apr 28 at 13:06
    
I'd say: do a fresh install of (G)ubuntu (with a build in Gnome instead of Unity) and try it from there. –  Joris Donders Apr 28 at 13:06
    
@JorisDonders how would I do that? All I can see is that there is no option to only use Gnome. Besides, I already have a ton of stuff on here, that I cannot simply get rid of and start from scratch –  o7th Web Design Apr 28 at 13:13
    
@AvinashRaj added to the question –  o7th Web Design Apr 28 at 13:15
    
@o7thWebDesign he is suggesting you use ubuntugnome.org which has the Gnome 3 de instead of Unity de. I have been using it for a few weeks, very nice. You may be able to upgrade to it, given the right upgrade commands and/or install media. –  0xSheepdog Apr 28 at 13:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.