Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running windows 8 natively and have installed Ubuntu 14 from their download page. I believe I have installed the 32bit version instead of the 64bit version, because it will not load the option to boot into Ubuntu at startup. I have to restart holding shift to get into an option to reboot a sata drive that has this version of ubuntu on it. What is the best course of action here? Uninstall Ubuntu? Upgrade somehow?

share|improve this question
    
32 Bit verison is backward compatible, and works on all 64 bit hardware. Its some sort of bootloader issue. Try going into the Bios/UEFI settings, disable UEFI secureboot, and enable legacy boot, and then restart –  Jay Aurabind Apr 28 at 9:45
    
I have done this already. That was the only way I could have even installed ubuntu in the first place. –  Grace Apr 28 at 9:47
    
In fact, Ubuntu is compatible with UEFI. Did you try it with Secure Boot enabled? Have you take the necessary steps mentioned in help.ubuntu.com/community/UEFI ? –  Jay Aurabind Apr 28 at 9:50
    
Did you answer No when the Ubuntu installer asked if you want to install Grub? –  katu txakurra Apr 28 at 9:53
    
I tried to install Ubuntu with secure boot enabled and was getting the error message no efi usb drive available. Once I disabled secure boot I was able to install ubuntu. I am using it right now. The problem as described above, is when I shut down for the night and want to reboot again, it only reboots into Windows 8 and does not give me an option to boot into ubuntu. I have to manually reboot into Ubuntu. I'd like to have an option to choose which OS I boot into at startup, which it is supposed to give me. I believe that 64bit Ubuntu would give me this option as it includes support for Uefi. –  Grace Apr 28 at 9:54

1 Answer 1

Either you can use boot-repair from an ubuntu live usb or easyBCD from Windows.

http://neosmart.net/EasyBCD/

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo sed 's/trusty/saucy/g' -i /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list
sudo apt-get update
sudo apt-get install -y boot-repair && (boot-repair &)
share|improve this answer
    
I have installed 64 bit ubuntu, but it has not fixed the issue. I went back into UEFI and changed boot order to legacy, so now it at least boots into Ubuntu first. I don't know what else to do to make it give me a choice of OS to boot into, but this is at least a work around. –  Grace Apr 28 at 19:31
    
I'm sorry to keep bumping this but I seem to have ruined windows 8 and cannot access the UEFI settings anymore. Is this fixable? –  Grace Apr 28 at 20:05
    
Make a bootable usb key with windows 8 repair (16Go at least I think) or use the installation CD to fix it. –  LittleNooby Apr 28 at 20:33
    
I don't have a windows install disk. Windows recovery media was installed on a separate partition. –  Grace Apr 28 at 20:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.