Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have seen many people have had problems with this topic and have tried pretty much every solution I can find (google is an ubuntu users friend) but still have not been able to get audio working through HDMI on my laptop with Ubuntu 14.04 (I also had the same problem with 13.10 and 13.04). Hence why I am writing this ask ubuntu question (my last hope). When I was running Windows 7 this was not an issue.

Laptop Information: 
3.13.0-24-generic
Graphics: Hybrid Graphics System
GPU/VPU: Intel HD Graphics 3000 and NVIDIA GeForce GT 555M

I am currently running the NVIDIA binary driver - version 331.38 (from additional drivers) I also tried using the X.org Xserver - Nouveau display driver Additionally I installed the oem-audio-hda-daily-dkms (alsa daily builds)

Information: The option for HDMI audio does not show up under sound settings so I installed the pulseaudio manager. However the option for HDMI output is always showing up as (unplugged). I also tried the gnome alsamixer with no luck.

With the alsamixer I can see the option for S/PDIF and even when I unmute it no option appears in the sound settings.

I added the GRUB_CMDLINE_LINUX="radeon.audio=1" option to the /etc/default/grub just for fun...

I checked all the settings on the TV just to make sure I wasn't missing anything.

I even tried the Bumblebee Project.

Let me know if I need to provide any additional information.

share|improve this question
    
Nvidia GTX 560Ti, Samsung TV, same situation. After installing and removing VLC phonon backend can't even test HDMI output in KDE settings. 3.13.0-24 –  int_ua Apr 29 at 1:21
    
audio works with nouveau drivers, but they don't see FullHD resolution, just 1280x800 –  int_ua Apr 29 at 4:36
    
It started working again today, check yours please. –  int_ua May 9 at 16:09
    
The audio is not working with the nouveau drivers or the nvidia drivers... I also tried the pavucontrol and the "Digital Surround 5.1 (HDMI) Output" and "Digital Stereo (HDMI) Output" still show up as (unplugged). –  user275243 Jun 17 at 3:37

1 Answer 1

Somehow KDE phonon settings don't show the needed HDMI output. The latest pavucontrol will show much more outputs with addition of plugged in/unplugged prefixes. Just select plugged in one.

share|improve this answer
    
Thanks. This worked for me. My issue (14.04) was with Nvidia through HDMI. I don't know what exactly I did; I just tinkered with the settings until sound came on. –  kelvinilla Aug 1 at 15:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.