Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

While installing pyscard.py I get this error,

gcc -pthread -shared -Wl,-rpath,$ORIGIN/../lib -g -L/home/builder/jenkins/workspace/Python_Masters/ARCH/x86_64/label/Linux/core/lib build/temp.linux-x86_64-2.7/smartcard/scard/helpers.o build/temp.linux-x86_64-2.7/smartcard/scard/winscarddll.o build/temp.linux-x86_64-2.7/smartcard/scard/scard_wrap.o -L/home/builder/jenkins/workspace/Python_Masters/ARCH/x86_64/label/Linux/core/lib -lpython2.7 -lpython2.7 -o build/lib.linux-x86_64-2.7/smartcard/scard/_scard.so
/usr/bin/ld: error: cannot find -lpython2.7
/usr/bin/ld: error: cannot find -lpython2.7
collect2: ld returned 1 exit status
error: command 'gcc' failed with exit status 1

I found this post with the same problem, I can't get it work though,can anyone clarify this for me please ? thank you

share|improve this question
2  
Have you done sudo apt-get install python2.7-dev? –  saiarcot895 Apr 27 at 21:09
    
waw, thanks !, i don't why, somehow i thought i already had it installed –  Abdou Abderrahmane Apr 27 at 21:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.