Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This may be a duplicate of question that another user has posted, but unfortunately when I try to access the question I get a message stating that the original question was removed for moderation reasons.

I previously had a working Ubuntu 12.10 installation that dual booted with Windows 8, although I had to run the recommended Boot-Repair setting to get Ubuntu working. I installed Ubuntu 14.04 from a DVD yesterday over my Ubuntu 12.10 installation and have found that, despite there being a Windows 8 entry in grub2, only Ubuntu will load. If I select the Windows 8 entry Grub reloads. I get a UEFI menu if I press F10 after switching on the computer, but the Windows entry loads grub. There may be an error message generated here, but it is only on screen for a fraction of a second and I've not yet been able to capture it. I have tried rerunning Boot-Repair using the Ubuntu 14.04 livedvd and the following commands:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo sh -c "sed -i 's/trusty/saucy/g' /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list"
sudo apt-get update
sudo apt-get install -y boot-repair && boot-repair

I selected the 'Recommended Repair' option and I got a warning about errors occurring and this link to share: http://paste.ubuntu.com/7340206/ As before, Ubuntu boots fine but I still cannot load Windows 8 either from Grub or from the UEFI menu. I do not believe that I have changed any BIOS settings since my successful Ubuntu 12.10/Windows 8 dual boot setup so I was expecting everything to work.

My computer is a Samsung Series 3 NP350V5C laptop and I have a recovery partition that I can access by holding F4 when turning on my computer. I don't believe that I have any other Windows utilities.

I am happy to provide further logs and pictures of my BIOS settings if required. I have also posted in the Boot-Repair thread on the forums as well as emailing [email protected] as advised by Boot-Repair. Thank you in advance for any help that you can offer.

Edit: as requested here is the update-grub output:

sudo update-grub

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.13.0-24-generic
Found initrd image: /boot/initrd.img-3.13.0-24-generic
Found Windows Boot Manager on /dev/sda2@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration
done

Also, this might be related to https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1308758

share|improve this question

4 Answers 4

Your problems are caused by an overzealous Boot Repair operation, which has resulted in GRUB being installed in place of the Windows boot loader. It may be possible to repair the damage by running Boot Repair again, entering the Advanced menu, and selecting the option to restore backed-up files. This should return the Windows files to their original locations, which should enable your new GRUB or the firmware's built-in boot manager to launch them. If that fails, you may need to use a Windows recovery disc to re-install the Windows boot loader.

share|improve this answer
up vote 0 down vote accepted

I can now boot Windows 8. Following instructions from the Boot-Repair team, I backed up my current bootmgfw.efi and reverted the backup copy:

sudo mv /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi /boot/efi/EFI/Microsoft/Boot/bootmgfw2.efi
sudo mv /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi.bkp /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi
sudo modprobe efivars
sudo update-grub

Upon rebooting my computer, I can now access both Ubuntu and Windows.

This might be similar to what happens in the process that Rod Smith suggests above, but I thought that I'd detail exactly what I did to restore my Windows 8 access.

share|improve this answer

I had a similar problem - Windows 8 machine that previously had dual boot working - did not allow Windows boot.

OP's solution (re-enabling the backed up EFI file) did allow me to boot Windows again - but then GRUB would not show and I was stuck with only Windows. I was able to re-enable GRUB by running this command in Windows:

Open an Administrator Command Prompt window and type:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

Credit

P.S. Added an answer because I'm not allowed to comment nor vote [??]

share|improve this answer

I solved the issues you comment several times using these methods:

From Linux (1st method)

After using the Boot-repair tool using an Ubuntu LiveCD/USB, please reboot. If you can get access to your installed Ubuntu OS, then install the Grub Customizer:

sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update && sudo apt-get install grub-customizer

You can open the Grub Customizer by searching "Grub" on Dashboard and verify if Ubuntu & Windows properly recognized and configured on List configuration (first tab). Also you can modify the desired OS to run, the time to wait until your preferred OS start and many more in the General settings (2nd tab), or use a theme/ your own background image in the Appearance settings (3rd tab).

From Linux (2nd method) If you can't get access to your Ubuntu installation after running the Boot-Repair tool and reboot, then download the SuperGrub2 disk. This LiveCD/USB tool help you to search&find any Boot record inside your HDD in order to help you to boot from it and repair any broken entry. I recommend you to play the video tutorial you'll find on the author's web page. After the broken Boot issue is solved, please use the Boot-repair program, or the Grub-Customizer tool I mentioned above...

From Windows (3rd method) If you can't boot into Ubuntu partition but Windows OS works fine, you have another method using the EasyBCD application. In a nutshell, EasyBCD is a free (for personal use) program that allows you to create any Boot entry from several sources, such as CD's/DVD's, USB drives, ISO image files, FAT/NTFS/Ext4 partitions and many more. I recommend you to read the guide you'll find on the official website, because here have some methods to made Windows & Ubuntu can coexist pacifically on your HDD.

From Windows (4th method) If none of these 3 previous methods works for you, the I suggest to create a new MBR using the recovery options your Windows8 have (no Windows install DVD is required).

If you can boot into Windows8, press the Windows+C combo key (no matter if you're on desktop or tiles mode) and click on "Settings" ->"Change PC Settings" -> "Update or recovery" -> "Recovery". Finally click the "Restart" button under "Advanced startup". After your computer restarts, you'll see "Choose an option". Please select the OS you want to repair, and click "Troubleshoot" -> "Advanced options" -> "Automatic Repair".

If you can't boot into Windows8, turn OFF your computer and then turn ON. Before the Windows Logo appear, press the F8 key several times until you see the advanced boot options. If you can get this screen, turn ON your computer and turn OFF while you see the "Windows is starting" message (or the Windows animation logo) and made this step a couple of times (normally 2 times is enough), until you see the advanced boot option (a message asking to "Repair your computer (recommended)" will appear). Using the arrow keys, select "Repair your computer" and hit Enter. (If this option is not available means your manufacturer doesn't include preinstalled recovery options; in that case you'll need to create a USB/DVD recoveryusing this guide ). Select the keyboard layout, and click "Next". Finally click "Startup Repair" on the System Recovery Options menu. if this process fail, then open the command prompt and put these commands and reboot:

bootrec /fixmbr
bootrec /fixboot
bootrec /RebuildBcd

These commands will help you to create a new MBR on your HDD. Later you can use any of the previous methods I described above to repair the Ubuntu Boot...

share|improve this answer
    
Most or all of your suggestions are suitable for a BIOS-based installation, but not for an EFI-mode installation, which Budoc has. –  Rod Smith Apr 29 at 0:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.