Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have got a graphic problem, but I don't have a clue how to find the source of it.

It seems like some parts of the display won't refresh when I am moving a window. It also has to be some software error, as it is shown on the screen shot below.

Screen shot of the error.

enter image description here

The Computer is a modified version of the Dell Vostro 3450. It uses the Intel HD Graphics of the built-in Intel I5. (Some more information: 16 GB Ram, 500 GB HDD and 128 GB SSD.)

I'm running the 12.04 LTS.

Here the output of the requested command:

lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

--

It also seems to be a unity problem. I switched to Gnome classic and it runs fine. Also this problem occured just two days ago.I didn't use the Laptop for about a week, started it 2 days ago(usually its always in standby-mode, but it may have run out of power) and then recognized the error. After that i installed all updates, but the error is still there.

--

Okay, its gone. I ran Ubuntu-Tweek's janitor, which basically clears/removes the apt-cache, old kernels, package configuration and unneeded packages. Then i restarted unity and it looks all good.

share|improve this question
    
Welcome to Asku Ubuntu! Can you post the output of lspci | grep VGA in your description? Also can you tell which version of Ubuntu you are using? It will be great if you can also provide more information about your hardware. –  Venki Apr 27 at 18:06
    
You must try installing the driver for your graphic card. –  Venki Apr 27 at 18:16
    
How do i do that? I tried the "additional Driver"-Option in the Systemsettings, but its not finding any driver. Also i'm running this System for about a year without that error and just 2 days ago it suddenly occors. –  ceec Apr 27 at 18:24
    
Strange..what did you do 2 days ago? did you do some update? –  Venki Apr 27 at 18:25
    
I did nothing. I didn't used the Laptop for about 1 week, started it (usually its always in standby-mode, but it may have run out of power) and then recognized the error. After that i installed all updates, but the error is still there. –  ceec Apr 27 at 18:29
show 6 more comments

1 Answer 1

This glitch is due to system cache accumulation. Therefore one can solve it by clearing cache. To do this one may use Ubuntu Tweak's 'Janitor' feature. For installing Ubuntu tweak use the following commands:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Then open it from the dash. One can also open it from the terminal with the command:

ubuntu-tweak

Then one should select Start Janitor. Then select the cache one desires to clear from the subsequent window and then press Clean to remove cache. This should remove all unnecessary cache and solve the graphical glitch too.

If this doesn't work one may try making edits in CompizConfig settings manager which can be installed from here:

Install via the software center

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.