Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, here's the story of this problem

I have my work laptop dualbooted with Windows7 and Ubuntu 12.04 LTS. I was doing preparations for a tutorial on openGL I wanted to do and I installed some packages, namely, libxmu-dev and libxi-dev. However, one of these changed like 20 packages that were largely the same but with xorg-* instead of xserver-* prefixes. When I rebooted several peripherals didn't work. I mistakenly destroyed the partition that held Ubuntu after making my backups but when I rebooted this message was lying in wait for me.

error: unknown partition  
grub rescue:  

I tried using ls to move around the partitions but no matter what I do I always get the same message.

error: unknown partition

I even tried reinstalling Ubuntu but the install process failed when it reached the grub configuration. What do I do? PS: Sorry If this is a common question, I read around the forums and everyone could read and modify their partitions on first try, not my case however.

share|improve this question
    
You should be able to reinstall from a live disc, it shouldn't matter how messed up the previous install is, as it will get totally wiped. Is your bootloader somewhere else besides in the ubuntu install? –  RhZ Apr 27 at 17:36
    
During the installation it said that the bootloader was in /dev/mmblck0 but such partition didn't exist. When I tried reinstalling it just said that grub couldn't be found and it was a fatal error, followed by the grub rescue prompt after a reboot. –  Francisco Garcia Apr 27 at 17:39

1 Answer 1

up vote 0 down vote accepted

Francisco mmblck0 is (propably) a SD Card in your laptop. I have similar problem and I was forced to reinstall grub from live CD. Some BIOS and GRUB don't read SD Cards for boot, so this is the problem. I think that solution proposed by RhZ is correct. You should boot from LiveCD login to your machine by chroot and then reinstall GRUB on any bootable partition.

share|improve this answer
    
When in doubt, reinstalling is always a decent if imperfect way to get things right. –  RhZ Apr 28 at 2:33
    
Surprisingly, this was the problem. After I removed the SD card GRUB complied to the rebuild process and I could get things right again. Thanks. –  Francisco Garcia Apr 28 at 20:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.