Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I upgraded from Ubuntu 12.04 to 14.04 Aptana Studio 3 doesn't work any more. When I try to open it after a few minutes it just closes, but when I open it in the terminal I got this error massage.

A fatal error has been detected by the Java Runtime Environment:

 SIGSEGV (0xb) at pc=0xa144786d, pid=3011, tid=3076155136

JRE version: OpenJDK Runtime Environment (7.0_51-b31) (build 1.7.0_51-b31)
Java VM: OpenJDK Client VM (24.51-b03 mixed mode, sharing linux-x86 )
 Problematic frame:
 C  [libsoup-2.4.so.1+0x5486d]  soup_session_feature_detach+0x1d

 Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again

 An error report file with more information is saved as:
 /opt/Aptana_Studio_3/hs_err_pid3011.log

 If you would like to submit a bug report, please include 
 instructions on how to reproduce the bug and visit:
   http://icedtea.classpath.org/bugzilla
 The crash happened outside the Java Virtual Machine in native code.
 See problematic frame for where to report the bug.

I tried to reinstall that frame using Synaptic, but it doesn't work. After that, I uninstall Aptana Studio. I installed it by this manual . I have used this manual before upgrade and after upgrade.

share|improve this question

3 Answers 3

up vote 6 down vote accepted

I had the same problem after upgrading to UBUNTU 14.04. For a workaround I added the following line to the end of "AptanaStudio3.ini" file (in your case it should be at '/opt/Aptana_Studio_3/AptanaStudio3.ini')

-Dorg.eclipse.swt.browser.DefaultType=mozilla

That worked for me (at least for the past hour since it used to close after few minutes), I hope it solves your problem as well.

share|improve this answer
    
thanks for response, but i managed to fix problem by installing Oracle java by this manual wikihow.com/Install-Oracle-Java-on-Ubuntu-Linux. But i gonna keep in mind your response because you can never know when you will need ir ;) –  rudis Apr 29 at 9:44
1  
worked for me! thanks you saved me so much cursing –  lelloman Apr 30 at 12:59
    
for some time worked my found cure but few weeks ago it crashed again but no fixed with editing aptana.ini as mentioned above. Thanks –  rudis May 24 at 18:42

After trying a lot of thinks, this worked for me (Ubuntu 14.04 + java 7 oracle): In a terminal:

ulimit -c unlimited

And it worked (until now)

share|improve this answer

-- never mind this didnt work after all --

I read somewhere that theres a problem with OpenJDK and its best to use OracleJDK. You can try remove OpenJDK first as i did or just go ahead and install OracleJDK.

These lines seem to fix it for me.

sudo apt-get install python-software-properties
sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
share|improve this answer
    
also i did actually blank my aptana.ini as well –  Daniel Lee May 5 at 19:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.