Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tested on Firefox and Chromioum. Im at 100% while loading pages which causes them to load slow and when I dont have a application running Im at 40% CPU (At least)

Everything is slow basically. Im also already on Ubuntu Classic so im not using Unity. Should I go to 10.04? is that more stable?

On windows this wasnt an issue. I have a Dual Boot with XP and a 2.4Ghz Intel Celeron with 768MB RAM and an Nvidia 6200 Graphics card.

I heard 10.04 was the most stable. any suggestions?

share|improve this question
    
possible duplicate of Why is Firefox too slow? –  Jorge Castro May 22 '12 at 6:46
add comment

3 Answers

What process is taking all of the CPU? Sounds like the browsers aren't the root of the problem.

You can find out using the 'System Monitor' utility (System->Administration menu). Select the 'Processes' tab, and sort descending by CPU. Or, you can run 'top' in a terminal window and sort by CPU (if not doing so by default, type 'OK').

share|improve this answer
4  
Except that in my experience, gnome-system-monitor hogs more resources than everything else in my system combined. However, that might just be me. ;) –  jrg Jun 3 '11 at 19:36
    
@jrg It's not necessary to run gnome-system-monitor all the time, just to see what else is hogging resources. When running it, even if it uses the most resources, the other processes will still probably use resources in the same proportions as they would when the System Monitor is not running. –  Eliah Kagan Nov 9 '11 at 19:25
add comment

I had a similar issue to this using Opera on 10.10. It turned out to having nothing to do with the browser at all, only that it was using up all my ram and I only had a tiny (64MB) of swap space. Once it hit that threshold it started making my computer chug.

Not sure if this is your issue, but if you suspect it is you might try creating and adding a swap partition if the one you have is small.

Some information on that: https://help.ubuntu.com/community/SwapFaq

The specs of your computer are pretty low though, so it could be a number of issues (and browsers these days go hog wild on memory and processing).

share|improve this answer
add comment

Little bit late on this one, but I'll almost guarantee its a flash issue, look for npviewer.bin processes (attached to Chrome or Firefox processes), and kill it/them. I've had it for a long while and seems to be consistent across all browsers when Flash plugin is in use.

I've noticed certain sites are much worse than others, and it'll usually be one tab that's causing it.

Hope this helps!

P.S Anyone know a fix to this issue?? I'm assuming as its flash, its closed and nothing can be done, but there must be a fix somewhere down the line!

share|improve this answer
    
Not all installations of Adobe Flash are such that npviewer.bin is what uses CPU when Flash is running. If you can look in the System Monitor or top to see what process is taking up the CPU, and post the information here, that might turn out to be Adobe Flash even if the process isn't npviewer.bin. –  Eliah Kagan Nov 9 '11 at 19:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.