Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used to run bumblebee successfully on my previous Ubuntu 12.10. But ever since I migrated to elementary os Luna, which is based on Ubuntu 12.04, I have been trying with no luck to get bumblebee Working.

When I run optirun glxspheres64, it says

[11119.768519] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initiate mode change.

[11119.768595] [ERROR]Aborting because fallback start is disabled.

Here's the output of optirun -vvv glxspheres64 ,

[11701.336788] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[11701.337274] [INFO]Configured driver: nvidia
[11701.337514] [DEBUG]optirun version 3.2.1 starting...
[11701.337555] [DEBUG]Active configuration:
[11701.337590] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[11701.337629] [DEBUG] X display: :8
[11701.337662] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia-331:/usr/lib32/nvidia-331
[11701.337686] [DEBUG] Socket path: /var/run/bumblebee.socket
[11701.337709] [DEBUG] Accel/display bridge: auto
[11701.337734] [DEBUG] VGL Compression: proxy
[11701.337757] [DEBUG] VGLrun extra options: 
[11701.337779] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
[11701.337847] [DEBUG]Using auto-detected bridge virtualgl
[11727.088558] [INFO]Response: No - error: [XORG] (EE) NVIDIA(0): Failed to initiate mode change.

[11727.088593] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initiate mode change.

[11727.088605] [DEBUG]Socket closed.
[11727.088639] [ERROR]Aborting because fallback start is disabled.
[11727.088652] [DEBUG]Killing all remaining processes.

And my /etc/bumblebee/bumblebee.conf is,

# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false

# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method, use at your own risk
#             none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia-331-updates
Module=nvidia
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia-331-updates:/usr/lib32/nvidia-331-updates
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-331-updates/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

Any idea how to fix this? Please help

share|improve this question

closed as off-topic by karel, Braiam, Eric Carvalho, nux, psusi May 17 at 19:49

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – karel, Braiam, Eric Carvalho, nux, psusi
If this question can be reworded to fit the rules in the help center, please edit the question.

    
I'd try to remove bumblebee completely, and install it again. –  Adobe Apr 27 at 17:43
    
Tried that already, a couple of times. Still shows the same error. –  user274780 Apr 28 at 14:05

1 Answer 1

12.04 might just be too old. Add the X-Updates PPA and then reinstall bumblebee.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.