Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just changed ISP and router, but now I have a problem.

It is no longer possible to see youtube movies, images from the page etc.. ytimg.com, which delivers the content (videos, css, images) on the youtube page is not working.

If I run XP in virtualbox youtube works just fine, it also works if I plug the cable from the WAN directly to my machine and set up PPPoE.

My Android phone has the same problem with youtube.

All other pages work as expected.

The router may not support Linux, But why are everythings Other wokring page? Is it possible to fix this?

Do you think I will have problems if I buy a Linksys E4200?

share|improve this question

closed as off topic by fossfreedom Feb 24 '12 at 21:54

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
You said that you don't see any resource from s.ytimg.com, have you tried opening one directly? E.g. s.ytimg.com/yt/imgbin/www-master-vflNOya8A.png –  Lekensteyn May 28 '11 at 7:29
    
I wonder if it is a DNS issue, are you using a custom DNS for linux and your phone that you are not using for windows? –  TheX Feb 24 '12 at 21:54
add comment

1 Answer 1

My immediate thought is that it is not a Linux/router compatibility issue. Why you are only experiencing this with Youtube is strange indeed. What type and model router are you using?

share|improve this answer
    
I am using a SMC WBR14-g. It works on windows machines, but not on android devices or Ubuntu. –  Alex May 28 '11 at 0:30
    
I am a little confused about your statement "All other pages work as expected". Are you saying that all other pages work as expected when using your Android phone, but not when you are using Linux? Have you demonstrated your Linux box is correctly configured to make wireless connections? The way I see it is that an 802.11 connection is an 802.11 connection. I tend to believe that it is likely a Linux configuration issue. –  Kory Wnuk May 28 '11 at 0:39
    
Sorry. What I meant was that all pages except youtube works on both Ubuntu and Android. Youtube works in a virtual Windows machine inside Ubuntu, but not in Ubuntu itself. –  Alex May 28 '11 at 0:52
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.