Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried different methods to do this, but almost always same point fails.

Normally when i boot into USB (or DVD, via USB) the install starts, but nothing happens for an hour. This is the most I've waited so far, wheel just keeps spinning... this happens after the selection of language and upgrades / propietary software.

I have followed different guides from Ubuntu sites, and also done the USB with different tools.

Only thing i can think now is this:

I have replaced my DVD with second SDD. Can this be the cause of this problem?

Normally when i boot to install with USB, i have to unplug externeal USB3-Hub so that only have the USB stick directly on my MBP. If i have external USB3-Hub connected i get reboot or freeze. I can connect the Hub after the LiveCD has booted and i'm on the desktop.

I can also install wireless and NVidia drivers when i'm in the LiveCD, or use my iPhone as wireless Network when i'm just trying to install directly.

Partition that have include OSX and Bootcamp (Win 8.1). I have tried also to install to "empty" space in Bootcamp or second SDD and so that i would resize the Win 8.1 size.

.. . and i use rEFIt on my MBP.

Any help ?

share|improve this question

1 Answer 1

Try the above procedure with rEFind. Many of my problems were solved after I changed from reFit to rEFind. Further, I hope you have checked the integrity of your installation file. Finally, you can follow this guide for instructions about installing rEFind and linux on macbook. This we very useful in my case of installing 14.04 on macbook 9,1

Though I forgot what command I used for installing it first time from my MacOS's terminal. But whenever I update and rEFind is gone I use the following command to reinstall:

sudo install.sh --alldrivers

Also, though not related to the above question I added a set of commands I use to setup my system from the begenning. After it has booted to a GUI for my macbook (9,1) with ubuntu 14.04. Its in script looking format but you need to manually enter many of them. Here it is: https://github.com/pranaysharma/linux_scrypts

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.