Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i upgraded to 14.04 and afterwards i got an issue with cpu usage when playing HD.

I checked the vainfo and this what i got back

ibva info: VA-API version 0.35.0
libva info: va_getDriverName() returns -1
libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
vaInitialize failed with error code -1 (unknown libva error),exit

I re install the driver sudo apt-get --reinstall install i965-va-driver but i steel got the same error.

Any thoghts

share|improve this question

1 Answer 1

A speculative answer given the brevity of the question.

A very recent thread in Arch Linux reported the same error.

Therefore two suggestions to try:

  1. Remove your xorg.conf file - I'm making the assumption you have one defined.

    sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
    
  2. reboot

If this doesnt work, you can revert using:

sudo mv /etc/X11/xorg.conf.backup /etc/X11/xorg.conf

Suggestion 2:

  1. Look at the contents of your xorg.conf file and change the AccelMethod value to "glamor"

    sudo nano /etc/X11/xorg.conf
    
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.