Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 14.04 LTS 64 bit . I know this question has popped up many times but I want to make it very clear that none of the posts helped me a bit.

my Problem: I am unable to get my custom wallpaper stored at /home/sudeepto/Pictures on the Ubuntu login screen . The screen shows me purple background and upon giving login credentials the graphics gets really scrambled for a while and then I can use my system just fine.

I guess since most of the articles are not Ubuntu 14.04 based, I am having such problems.

Things that I tried:

I followed this post on askbuntu . I tried both the suggestions but no luck.

I don't know how to take screenshot of unity-greeter, otherwise I would have given links to my login screen as well.

Please tell me what should I do next to solve this problem which I never faced in previous versions of Ubuntu.

share|improve this question
    
ive encountered this before i cannot change the background of lightdm greeter, but since my system update on 07/04/14.. all be seem fine now.. when i change my desktop wallpaper, it shows also in lightdm greeter automatically. –  xsoultribex Jul 4 at 14:52
    
What was installed? What changed? –  0xC0000022L Jul 4 at 17:16

1 Answer 1

up vote 1 down vote accepted

To change the background of the login screen (based on this answer):

sudo -i
xhost +SI:localuser:lightdm
su lightdm -s /bin/bash
gsettings set com.canonical.unity-greeter draw-user-backgrounds 'false'
gsettings set com.canonical.unity-greeter background 'path-to-image'
exit

This will only change the background of the login screen. If you also want to change the background of your lock screen, you should also execute the following commands as each user you want to change the background for:

gsettings set com.canonical.unity-greeter draw-user-backgrounds 'false'
gsettings set com.canonical.unity-greeter background 'path-to-image'

I can confirm this is working on 14.04 LTS.


By setting draw-user-backgrounds to false you can set a custom background.

Obviously you should replace path-to-image by an absolute path to the image you want to use. Make sure the lightdm user has read permissions for this file.


Optional tweaks you might like

You can also change the background color which you'll see in a flash (default purple) before your background is loaded. To do this, execute the following command after the other gsettings commands (this will change the color to black):

gsettings set com.canonical.unity-greeter background-color '#000000'

And you can disable the dots on the login screen by executing the following:

gsettings set com.canonical.unity-greeter draw-grid 'false'

And also remove the greeter sound

gsettings set com.canonical.unity-greeter play-ready-sound 'false'
share|improve this answer
    
So do i need to do apply these settings for every wallpaper that I use other than the default ones ?? I mean is there a way so that whenever I add wallpapers inside the /home/sudeepto/Pictures folder it automatically apply the aforementioned settings for them as well?? –  sud_the_devil Apr 26 at 16:09
    
If you want to change the wallpaper, you'll have to execute the commands again, or you can just overwrite your last background image with a new image. –  Louis Matthijssen Apr 26 at 16:13
    
I am sorry but I didn't understood the difference between overwriting the image and changing it . Suppose I chose a different wallpaper from the Pictures folder, so do I need to execute all the above commands again or changing the wallpaper will automatically set my login screen to the new wallpaper. –  sud_the_devil Apr 26 at 16:30
    
If you set your wallpaper like this, Unity will open the image (for example /home/sudeepto/Pictures/bg.jpg) every time, so you can just overwrite bg.jpg and Unity will load your new bg.jpg. If you want to use the same background as your desktop's background you should set draw-user-backgrounds to true, but this is the default setting so then I wonder why you asked this question. –  Louis Matthijssen Apr 26 at 16:57
    
Okay, Yeah I wanted to know how can we add a different as well as the same wallpaper as the desktop background since I'm having problems's with the login screen only showing purple screen. Anyways, can you please tell me what do you mean by this line?? Make sure the lightdm user has read permissions for this file. ?? –  sud_the_devil Apr 26 at 17:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.