Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently installed Xubuntu 14.04 on two computers. Computer A is a DELL Aptitude E5430 laptop, whereas Computer B is a home-mounted desktop, with an ASUS H87-Plus motherboard. I have been trying to make an EPSON Perfection V33 scanner work with both computers, with mixed results.

First of all, I downloaded the appropriate programs from the Epson site and installed all three of them on both computers.

My DELL has 4 USB connectors: one at the right-hand side (USB2), one at the back (USB2) and two at the left-hand side (one USB2 and one USB3). If I plug the scanner into the connector at the right-hand side, I can run Image Scan! and Simple Scan without any problem. However, if I use either one of the other two USB2 connectors, the problems start: the sane-find-scanner utility finds and identifies the scanner; and scanimage -L works OK as well; but when I try to run Image Scan! the scanner produces the customary humming noises, the ON lamp blinks for a few seconds, but the Image Scan! screen never appears, and after a while the program disconnects and sends the following message:

Could not send command to scanner. Check the scanner's status.

If I run Simple Scan, the initial screen appears, but I cannot make it scan anything.

It turns out that when I plug the scanner into connector 1, the Linux kernel assigns ehci-pci to it; when I use connectors 2 or 3 it assigns xhci_hcd. I have no idea why this happens. Anyway, I think it explains why scanning cannot occur when connectors 2 or 3 are used, because the Epson drivers for this scanner are known to be incompatible with USB3.

To confirm this, I then plugged the scanner into one of the USB2 connectors of computer B (the ASUS desktop). As with my laptop, sane-find-scanner and scanimage -L showed no problem. But, sure enough, xhci_hcd was assigned to the scanner, and scanning failed, despite the humming and blinking. I then disabled USB3 via BIOS; this time ehci-pci was assigned to the scanner, and scanning proceeded normally.

I want to keep the scanner plugged to the ASUS desktop in my office, but disabling USB3 on this computer every time I need to scan is obviously inconvenient. So here is my question: could I make the kernel assign ehci-pci to the scanner instead of xhci_hcd (maybe through a udev rule)? So far I have been unable to find a clear answer or a good solution, so any help will be appreciated.

Many thanks in advance.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.