Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have zeitgeist daemon always in processes. I don't see the point of this zeitgeist, it logs my activity. i removed it from startup programs, but it is still there.

Can I uninstall this package? Why do I need it at all?

share|improve this question

4 Answers 4

up vote 14 down vote accepted

For Ubuntu 14.04

Follow this answer.

For Ubuntu versions prior to 14.04

N.B. do not run this on 14.04 because it will uninstall Unity

Run sudo apt-get remove zeitgeist* in a terminal. It might remove a few related packages, but so long as you don't see anything suggested for removal that you don't want, you should be fine.

As per comments: you will lose unity functionality (I was not sure how much when I first wrote the answer) if you remove zeitgeist. So, I suggest you just disable logging.

If you don't need unity to function correctly, you can go ahead and remove zeitgeist, and just use the classic session (from the login screen).

You can also blacklist everything or turn off logging altogether.

share|improve this answer
1  
You can see what will be removed by executing sudo apt-get remove --dry-run zeitgeist* before removing zeitgeist –  test30 Sep 1 at 12:06

If you remove Zeitgeist then the menu in Unity wont work properly, it stops you searching for programs by typing into the box.

share|improve this answer
2  
In Ubuntu 14.04 running sudo apt-get remove zeitgeist* will uninstall the Unity system –  Dan May 14 at 8:08

There is an easy way described here -- which does not include deleting any package, but simply de-activating the corresponding services. I didn't try it myself, but this way side-effects should be minimal (and probably even wanted, as e.g. no "recent items" being available etc. Moreover, it is easily revertable in case of "unwanted" side effects.

The author of that article explicitly states: Here is a way to disable this logging without breaking Unity or any other part of the system, execute these commands in a terminal:

sudo mv /etc/xdg/autostart/zeitgeist-datahub.desktop /etc/xdg/autostart/zeitgeist-datahub.desktop-inactive
rm ~/.local/share/recently-used.xbel
mkdir ~/.local/share/recently-used.xbel
rm -rf ~/.local/share/zeitgeist

Reverting this (if one wants to enable Zeitgeist again) thus should be done like this:

mkdir ~/.local/share/zeitgeist
rmdir ~/.local/share/recently-used.xbel
# no action for the .xbel file, as it will be re-created automatically
sudo mv /etc/xdg/autostart/zeitgeist-datahub.desktop-inactive /etc/xdg/autostart/zeitgeist-datahub.desktop

which is simply "reversing" the steps of the de-activation.

Remark: The ~/.local/share/recently-used.xbel has nothing to do with Zeitgeist itself, it just falls into the same category somehow. The article mentioned is about "disabling activity logging", and thus included this. If you just want to disable Zeitgeist, you can skip the two middle steps.

share|improve this answer
    
I followed the same procedure but it is not working for me: freshly installed 12.4.3, amd64-desktop version. "ps -ef" keep showing zeitgeist restarted after reboot, and the ".local/share/zeitgeist" directory recreated as well. –  Peter Teoh Nov 13 '13 at 4:22
1  
It works for me (lubuntu 14.04). I strongly suggest to follow this guide, since removing zeitgeist packages can broke dependencies. Please don't be overzealous. –  Lucas Malor Nov 12 at 15:17
    
Exactly my intention: show a way that can easily be "reverted", while minimizing impact on the system :) –  Izzy Nov 12 at 17:13
    
Is this up to date? –  Seth Dec 13 at 2:03
    
@Seth I can't say for 14.04 as I'm not using that (the one Ubuntu machine left with me is still on 12.04, for the others I've switched to Debian or Mint). Recommend to ping Lucas for this (see upvoted comment above), as he's confirming it for 14.04. –  Izzy Dec 13 at 11:45

I found hints about renaming of /etc/xdg/autostart/zeitgeist-datahub.desktop, but it isn't enough. It prevents Zeitgeist from running at startup, but in my case (Ubuntu 12.04.4 LTS) it started later somehow (perhaps as a result of some DBus activity).
If you'd like to keep Zeitgeist installed, but prevent it from running, try renaming its executables:

zeitgeist-daemon --quit
cd /usr/bin/
sudo mv zeitgeist-daemon zeitgeist-daemon.bak
sudo mv zeitgeist-datahub zeitgeist-datahub.bak

Now Zeitgeist daemon won't start. You can check this later with ps aux | grep [z]eitgeist. You can also purge the database which was collected by Zeitgeist by deleting ~/.local/share/zeitgeist/ folder with its contents, if you like to save some space.
To secure these files from updating you can also lock packages zeitgeist-core and zeitgeist-datahub in Synaptic or Aptitude.

To revert the changes simply rename these executables back:

cd /usr/bin/
sudo mv zeitgeist-daemon.bak zeitgeist-daemon
sudo mv zeitgeist-datahub.bak zeitgeist-datahub

If you altered .desktop file in /etc/xdg/autostart/, you should also return it back.

share|improve this answer

protected by Community Nov 28 '11 at 16:44

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.