Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I keep getting a blank screen and lose my Spotify Stream after about 10 to 15 minutes. The problem I am having is with light locker. In my case I cannot get light locker settings to open at all.

I wanted to disable this feature as it keeps interrupting my music stream. I am brand new to Linux. I have an Asus Eee901 netbook, With 2 GB of Ram, 128 SSD with Xubuntu 32 bit installed on it.

I use a netbook for web browsing and I use Google Chrome and streaming Spotify, and that is about it. Also, would Lubuntu allow me to use Spotify to stream?

Thanks in advance...

share|improve this question

2 Answers 2

There are a few reported bugs with lightlocker giving blank screens (e.g. after unlock after lid close).

My suggestion for a work around is to remove light locker and install Gnome screensaver or X screensaver instead.

To remove light locker run the following command: sudo apt-get purge light-locker light-locker-settings

To install Gnome screensaver: sudo apt-get install gnome-screensaver

OR

To install X screensaver: sudo apt-get install xscreensaver

share|improve this answer

FROM: http://xubuntu.org/news/screen-locking-in-xubuntu-14-04/

What happened to my music playback?

As your seat becomes inactive, your audio stream is stopped/paused until you log into your session again. This is one of the known issues of light-locker or locking with LightDM in general.

Currently, when locking, it is assumed you are either:

  1. in a public space of sorts (the desktop at home hardly needs locking) and have walked away from the machine
  2. using a system with more than one user

Stopping/pausing playback in both of these scenarios make sense.

However, this might be an annoying change for users used to having their music playback continue even when their session locks. If you don’t like this behavior, there are basically two solutions:

  1. Set light-locker to lock the session “When the screensaver is deactivated”
  2. Switch back to using xscreensaver
  3. Add your user to the “audio” group on your computer and music playback will continue also with light-locker

The first option is a good workaround, because it means that your audio-playback will continue when the screen has been blanked. However, when you wake up your computer, e.g. by touching the mouse, it will pause the music until you log into your session again. The third solution is mentioned last, because it isn’t advised to add your user to the “audio” group (read The Audio Group wiki page for a comprehensive explanation). However, as long as you’re on a single-user system, this might still be an option for you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.