Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've added the xorg-edgers PPA using sudo add-apt-repository ppa:xorg-edgers/ppa. Then I've tried different packages, all with the same problem. I'm currently using nvidia-331 as it's working almost perfectly.

The only problem that's left is that nvidia-settings is working perfectly when I'm using nVidia graphics, but as soon as I switch to Intel graphics (I'm on a notebook with nVidia Optimus) nvidia-settings won't open (it crashes instantly). Executing nvidia-settings in the terminal only gives me:

** Message: PRIME: Requires offloading
** Message: PRIME: is it supported? yes
Segmentation fault (core dumped)

I used the following commands to install nvidia-331:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get --purge remove nvidia*
sudo apt-get --purge autoremove
sudo apt-get install nvidia-331
sudo apt-get upgrade
sudo apt-get dist-upgrade

I can't use the nVidia drivers in Ubuntu's repository as the performance is horrible on my Notebook. However, nvidia-settings never had those problems using Ubuntu's repository.

Update: seems to be a bug (LP #1214508). However, they claim all packages >= 319 are affected, but it was working just fine using nvidia-331 from Ubuntu's repository.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

My experience is that anything from xorg-edgers PPA is just for those who really knows to fix their system. I spent a lot of time doing so (reverting packages). Therefore I really recommended removing this PPA after you install the latest NVIDIA driver. By the way: I'm reverted back from 337/334 to 331.38 nvidia version (from standard 14.04 repository) since I need CUDA and OpenCL support.

Now back to the topic: - I don't think that we, as a NVIDIA proprietary driver users, can do anything about the buggy NVIDIA PRIME tools.

How to revert back to your discrete NVIDIA card:

1.) "sudo prime-select nvidia" proposed by Louis Matthijssen worked in my case. Of course I logged out and in afterwards.

2.) Another "solution" would be switching from NVIDIA Optimus to "Discrete card" in your BIOS (if you have there such an option). (not tested)

share|improve this answer
    
Yes, I'm using nvidia-current from Ubuntu's repository now and everything is working as it should now (so far). I didn't want to use this one as I'm experiencing lag spikes in games when I'm using it, but this seems to solve itself after a few minutes gaming. –  Louis Matthijssen May 14 at 15:34

I have exactly the same issue. If I remove all the Nvidia packages and Prime and re-install and then reboot without changing anything I get access to the Nvidia settings. As soon as I swap to the IGP I can no longer swap back to the discrete GPU.

I have tried with different nvidia drivers and it is exactly the same result. Initially I was getting ACPI errors in the logs but now it just logs the Segment Faults (error 4 in libc-2.19.so).

Any ideas?

share|improve this answer
    
You can still switch using sudo prime-select nvidia or sudo prime-select intel, but it's just annoying that it doesn't work. Also, this is not really an answer. –  Louis Matthijssen Apr 27 at 14:16
    
How does this answer the question? Please take a few minutes to go through the site tour to get a general idea of how this site works and how to make the most of it. –  hmayag Apr 27 at 14:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.