Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I like having focus prevention set to high, so that I don't have some stupid auto-launched app steal my typing in the middle of something else. Unfortunately, Unity keeps focus on the right window while raising the new one. A number of times, this has caused me to close an application by accident that had control of the menu bar, even though it was underneath the new window. Is there a way to prevent raise without focus?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

I never did get this to work right in 11.10, in spite of tweaking CCSM and other antics. My final answer? Upgrade to 12.04; precise got unity in to much better shape for prime time.

share|improve this answer

I had the same problem and solved it by going into CCSM > General Options > Focus & Raise Behaviour. There, all I did was change the Focus Prevention Level to Low. Now, when I open an application via the Dash, it open up on top and has focus.

share|improve this answer

In CCSM, under General Options, you can play around with the auto-raise and its delay.

I would guess that having auto-raise on, and the delay set to 0, would keep the window in focus on top, regardless.

I must admit I'm struggling a little to understand exactly the behavior you want, or how to duplicate it; so this might be a little bit off the mark.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.