Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Chrome opens up in a maximized windows. No matter how many times I resize it down it stays the same on new windows. I tried resizing the windows then quitting Chrome, but still no luck.

If anything is there a way I can manually set the default window size through the shell or something?

share|improve this question
    
I dont know what kind of OS version you are using. But on my comp it seems to be a damned bug in UBUNTU 11.X. Those dummheads are opening ANY kind of new application window in fullscreen. :(( –  user31015 Oct 27 '11 at 23:32
2  
@Alberto Your issue may be related to screensize if it's small enough. You can try adjusting the "Automaximize value" setting in ccsm if you're using 11.10: askubuntu.com/questions/29553/how-can-i-configure-unity/… –  WarriorIng64 Nov 17 '11 at 0:31
    
@WarriorIng64, that solved my problem. No more automaximizing window for Google Chrome ;) Thanks. –  victorhqc Dec 19 '11 at 6:29
add comment

3 Answers

Aha! I think I've discovered why this is happening for me at least. Oscar, you didn't mention using two screens but I suspect you are (?). If not, mine may be a separate issue.

When I have a chrome window on my external monitor that is taller than my primary screen and I open a new window, it's full screen on my primary screen. If I adjust the height making it short enough to fit on my primary screen, it opens as expected.

I suspect any application that creates new windows of a particular size would exhibit the same behavior, I don't know anything else on my computer that does that though. Maybe Alberto can experiment with this.

share|improve this answer
1  
That seems to be the same as for me also! My 'primary' monitor is 1680x1050 but my 'secondary' is 1920x1080. –  Jayson Rowe Feb 20 '12 at 14:44
add comment

How is Chrome being opened? Specifically, I am curious about the command issued by the launcher. The reason for my interest is that the '--kiosk' modifier is used to open Chrome in fullscreen mode. Subsequently, I would check to ensure the '--kiosk' is not in the command line.

share|improve this answer
    
Not sure... I just installed it through the Software Manager then i click on on the dock on the side. Im in 11.04 –  Oscar Godson May 27 '11 at 16:05
    
Ahhh...so we are not talking about fullscreen so much as we are talking about Chrome starting maximized. Check to see if the '--start-maximized' startup switch is being called out. –  Kory Wnuk May 27 '11 at 16:13
    
Try this: Go to Ubuntu Control Center, select Main Menu. Navigate through the Main Menu utility until you find Chrome. Then select Chrome and click the properties button. This will allow you to look at the command line launching Chrome. –  Kory Wnuk May 27 '11 at 16:21
    
This is what i have there: /usr/bin/chromium-browser %U? –  Oscar Godson May 27 '11 at 16:27
    
I am not sure what the %U is, but suspect that is not the problem. Have you tried the suggestion offered up by @daithib8? Might be worth a shot. I guess I am curious to know if the CCSM workaround prevents Chrome for ever being maximized. –  Kory Wnuk May 27 '11 at 16:37
add comment

In compiz settings (ccsm) under Window Rules, put class=Chromium-browser in the no_maximize_match field.

share|improve this answer
3  
Im at work, and cant test, but will this make it so its never able to maximize? –  Oscar Godson May 27 '11 at 17:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.