Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Hard disk drive got too hot after a while of running Ubuntu. I've checked the system monitor and there weren't any thing strange.

I have Packard Bell EasyNote TJ75 with ATI card 512MB core i5.

share|improve this question
    
It could just be the way your computer is designed. Have you tried with another operating system? –  Ethan Turkeltaub May 27 '11 at 13:56
    
You need to know the actual temperature of the hard drive and its thermal specification. Use lm-sensors for the former, and the hard drive manufacturer's documentation for the latter. sudo lshw -class disk should tell you what kind of hard drive you have. –  ændrük May 27 '11 at 15:07
    
Indeed, what is "too hot" and how do you know? –  psusi May 27 '11 at 15:08
    
@Ethan Turkeltaub it's normal in windows 7 @psusi i can't touch it –  eyadof May 27 '11 at 15:39
    
That doesn't really clarify things. Check the temperature in the disk utility. –  psusi May 27 '11 at 17:24

2 Answers 2

up vote 3 down vote accepted

Are u facing the issue on laptop or desktop?

I faced this issue and after much struggle, I am able to resolve the issue. I was not able to use my laptop as my HDD was getting too hot.

Do the following and come back with the result.

  1. install powertop
  2. run it in sudo and go to the last tab in that application.
  3. Check if you are seeing some thing like "SATA Link..." as bad power setting.

If you see as above reply to this mail. I will provide the solution.

Good you have the same problem. Try these

  1. Follow the link to install TLP TLP
  2. Once installed open the file /etc/default/tlp
  3. Search for SATA in that file.

make the changes as follow:

#SATA aggressive link power management (ALPM):

#min_power/medium_power/max_performance

SATA_LINKPWR_ON_AC=min_power

SATA_LINKPWR_ON_BAT=min_power

  1. If you still want more optimization follow these a. Add noatime,nodiratime to your root mount disk property in /etc/fstab

Here is my example:

UUID=2961c207-9781-425e-9e6e-18641b21e52c / ext4 errors=remount-ro,noatime,nodiratime 0 1

Reboot the machine for all changes to take effect.

Do this you HDD will cool down. :)

share|improve this answer
    
yes i see this line : SATA link power management as bad power setting ad you say –  eyadof Dec 22 '11 at 18:55
    
See my updated comment. –  Abhijeet Dec 23 '11 at 3:58
    
SATA link power, is literally that, power management for the link between the hard drive and the motherboard. At the most, this can knock off 1 or 2 W of power. Not much. –  tumbleweed Dec 23 '11 at 6:22

It may be that the hard drive is dying, I worked in a computer repair store and the general point of no return is when you touch the drive and practically burn yourself, I would reccomend getting a new hard drive ASAP, @Ethan Turkeltaub, It is very rare for a hard drive to overheat enough to be noticed just because of the way the computer is designed, if such were the case, then the drive would die within a year of being new, just from excessive heat!!

share|improve this answer
    
thank but the promlem was from the ATI Card Driver it's normal now –  eyadof May 27 '11 at 15:40
    
True, true. –  Ethan Turkeltaub May 27 '11 at 22:10
    
Sorry to give you the -ve point but you are guiding the user to wrong direction. You are not considering all the possibility of issues. You are right that HDD start getting hot when they are about to die but in Linux there are many parameters which can cause the issue. –  Abhijeet Dec 23 '11 at 11:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.