Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There are many similar post on ask ubuntu and I have gone through them with little success.

I upgraded from 13.04 to 13.10 to 14.04 back to back. The upgrade from 13.03 to 13.10 worked fine. After the upgrade from 13.10 to 14.04 I ran into a problem. After logging into my computer I am left with only the background image and no other desktop or unity elements. No key bindings work ( ctrl+alt+t for example). I am able to drop into a terminal using ctrl+alt+(f1+f6). Once logged into a terminal I am able to run things like apt-get and other shell utilities. I can not run anything graphical without first telling the terminal where to send it by exporting display 0 export DISPLAY=:0 Once I have done that I can run gui based programs like Firefox.

One thing to note, if I run nautilus from the terminal it shows me the desktop and the bar at the top of the screen with the nautilus options ( File Edit View Go Bookmarks Help ). I have tried re-enabling unity from CCSM, no change, I have reinstalled unity and Ubuntu-Desktop, no change. I have uninstalled and reinstalled nvida-current drivers , again, no change.

I have done everything I can think of to investigate this problem ( which is not much since I am still pretty new to this). If there is anything I should do to further investigate this let me know and I will run it asap. I am still able to switch the standard output to a file on the desktop and access it from there. Any help would be greatly appreciated

  • edits to grammar and spelling were applied.

Update:

Based on the suggestions made in this post. I did the following;

sudo apt-get install --reinstall ubuntu-desktop sudo apt-get install unity sudo apt-get purge nvidia* bumblebee* sudo apt-get install nvidia-prime sudo shutdown -r now

Now, after I log into my computer I see the items on my desktop. I can also open nautilus by pressing ctrl+n. The ability to right click has returned which allows me to open a terminal. However, ctrl+alt+t still does not work. I am unable to grab and move any windows around or bring program windows from the back of the desktop to the front by clicking on them. They stay stacked in the order I opened them, with the most recent window on top. I checked Compiz Setting Manager again and unity is activated.

Update 2:

I think this may be an opengl problem. I ran the following command in the Termial;

DISPLAY=:0 unity

and I get the following output before the terminal hangs.

compiz (core) - Info: Loading plugin: core compiz (core) - Info: Starting plugin: core unity-panel-service start/running, process 2707 compiz (core) - Info: Loading plugin: ccp compiz (core) - Info: Starting plugin: ccp compizconfig - Info: Backend : gsettings compizconfig - Info: Integration : true compizconfig - Info: Profile : unity compiz (core) - Info: Loading plugin: composite compiz (core) - Info: Starting plugin: composite compiz (core) - Info: Loading plugin: move compiz (core) - Info: Starting plugin: move compiz (core) - Info: Loading plugin: place compiz (core) - Info: Starting plugin: place compiz (core) - Info: Loading plugin: snap compiz (core) - Info: Starting plugin: snap compiz (core) - Info: Loading plugin: commands compiz (core) - Info: Starting plugin: commands compiz (core) - Info: Loading plugin: compiztoolbox compiz (core) - Info: Starting plugin: compiztoolbox compiz (core) - Error: Plugin 'opengl' not loaded.

compiz (core) - Info: Loading plugin: resize compiz (core) - Info: Starting plugin: resize compiz (core) - Info: Loading plugin: regex compiz (core) - Info: Starting plugin: regex compiz (core) - Info: Loading plugin: mousepoll compiz (core) - Info: Starting plugin: mousepoll compiz (core) - Info: Loading plugin: imgpng compiz (core) - Info: Starting plugin: imgpng compiz (core) - Info: Loading plugin: vpswitch compiz (core) - Info: Starting plugin: vpswitch compiz (core) - Info: Loading plugin: session compiz (core) - Info: Starting plugin: session compiz (core) - Info: Loading plugin: workarounds compiz (core) - Info: Starting plugin: workarounds compiz (core) - Error: Plugin 'opengl' not loaded.

I am not sure what to do about this, opengl does not seem to be missing in general since i am able to run graphically intensive programs. However, I am not sure if the opengl plugin is a different thing then opengl used for things like gaming ( I feel shame admitting that ). I am off to do research on this and will report back when I have some more information.

share|improve this question
    
I believe 14.04 uses the xorg graphics driver. Perhaps your system is incompatible? –  BackTRanito Apr 24 at 22:20
    
I wouldn't think that is the issue because I am getting the desktop image. Additionally I can run steam games like DOTA2, so I am pretty sure the nvida driver is working, for the most part anyway. –  G.Oxsen Apr 24 at 22:27
    
possible duplicate of Unity doesn't load, no Launcher, no Dash appears –  jkt123 Apr 25 at 1:44
    
I have already looked over that one, Although it is a similar issue, it is from 3 years ago and the solution did not solve my issue. I have walked through all of the suggested answers in that post and also run into a brick wall. In the process right now of trying some of those solutions again since I have made changes to my system ( as noted in my update above ) –  G.Oxsen Apr 25 at 2:55

2 Answers 2

up vote 0 down vote accepted

OP here, I finally had success!

I am combining all of the steps I ended up doing before I had success

sudo apt-get install --reinstall ubuntu-desktop sudo apt-get install unity sudo apt-get purge nvidia* bumblebee* sudo apt-get install nvidia-prime sudo shutdown -r now

After the restart log back in and drop to a terminal in any way you can. At this point I was able to open a terminal by right clicking a blank place on the desktop and selecting open in terminal. Them enter the following set of commands

DISPLAY=:0 unity dconf reset -f /org/compiz/ unity

and unity finally started right up and everything is working fine now.

if the command unity does not start it back up at the end try setsid unity

I hope my trials are helpful for someone out there. Thanks to anyone who gave this thread a look and everyone who commented.

share|improve this answer

Thanks this fixed my issues too, I would have commented and up-voted, but don't have the rep.

One little twist I had to add was after starting unity I had to change my graphics drivers back to the Nvidia 331 (propriety, tested) drivers (not sure how it got changed).

share|improve this answer
    
I am glad this was able to solve your problem. I am sure this approach is akin to using a bazooka to kill a gnat, but it was the only set of things that worked for me. Hope you enjoy 14.04 :) –  G.Oxsen Apr 30 at 2:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.