Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

At work I can only connect to a specific ntp time-server. Under Ubuntu 10.10 I was able to add that server somewhere under time/date settings. Now under Ubuntu 11.04 I cannot find that option anymore.

I am sure that there is a config somewhere that I can edit to add the approved server.

Can you please give me some pointers?

Edit: I should probably mention that I use the classic desktop.

share|improve this question

1 Answer 1

up vote 7 down vote accepted

You'll have to do some manual editing using nano, or your editor of choice:

sudo nano /etc/default/ntpdate

and change the NTPSERVERS="ntp.[your-server-here]"

If you restart your computer this change will be made active. If you're feeling impatient and don't want to wait for the server to automatically update you can do it manually:

sudo ntpdate-debian

I can't see a GUI option for this, but I could be wrong.

share|improve this answer
    
I rebooted afterwards, but do you know how long it would take, until the clock is set according to the time server? –  bjoernz May 27 '11 at 10:18
1  
you can force it do update manually: using sudo ntpdate-debian; i've just updated my answer to reflect this. –  thomas michael wallace May 27 '11 at 10:28
    
Great, thanks, I will probably search for this after I install 11.10. Hopefully this will still work. –  bjoernz May 27 '11 at 10:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.