Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was trying to get MAAS cluster controller running on Ubuntu 14.04 using a clean server install and adding the MAAS package for the cluster-controller manually later. I have another machine running the maas-regional-controller.

I have two issues with the controller installation:

  1. Apache 2 hangs when installing the maas-cluster-controller package, due to some missing python module called crochet
  2. maas-pserv crashes with error code 1, gets re-spawned and finally is stopped by init, due to the high frequency of the restarts.

I installed the python-crochet package, in order to make apache start. Is this something due to some omission in the dependency list of apache installation? Hopefully it was ok to install the package in the first place.

The maas-pserv does not start and I don't know due to which cause. I tried to look into the log files in /var/log/maas, but pserv does not write any log file, maybe since the crash is created by upstart. I tried to start pserv manually through the twistd call as in /etc/init/maas-pserv.conf. twisted complains that it does not know the command maas-pserv.

By no means I'm a python expert, but I only can imagine (educated guess) that twisted is not importing the maas python application library and therefore complains about not knowing about it.

An ideas why maas-pserv is crashing?

share|improve this question

1 Answer 1

For the maas-pserv problem i've maybe a solution. I had the issue today also on one of my MAAS controllers and i found out that twistd has a cache file that contains all plugin information.

I simply deleted the dropin.cache file and twistd will find the maas-pserv now.

dropin.cache is located on /usr/lib/python2.7/dist-packages/twisted/plugins at my machines.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.