Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a server built a few days ago with 12.04.4 LTS. I am trying to upgrade it to the latest version. What am I doing wrong?

root@Ubuntu-server:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.04.4 LTS
Release:    12.04
Codename:   precise
root@Ubuntu-server:~# cat /etc/update-manager/release-upgrades | grep Prompt
Prompt=normal
root@Ubuntu-server:~# do-release-upgrade 
Checking for a new Ubuntu release
No new release found

Thanks for your help! -- Hope this is not a duplicate.

share|improve this question
    
Have you tried solutions here? askubuntu.com/questions/124999/… –  Nattgew Apr 24 at 15:42
    
Sort of. I turned on my machine back to try Joshka's solution (removing the file in /var/lib/...). But fired a last do-release-upgrade before that, and ... it worked! Not sure what happened after I turned off and on my machine. But askubuntu.com/questions/124999/… is a great source of info. Thanks! –  user273495 Apr 25 at 17:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.