Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Huawei 3276 4G modem but I can't get it working on ubuntu 13.10. I also tried to upgrade to 14.04, but it didn't fix it, and had to downgrade to 13.10 because of some problems. Several posts about this modem already exist, but I can't try their solutions. There is this script:

which is supposed to work, but when I launch it, I get:

$ sudo ./huawei-4g-linux.pl  Huawei 4g modem
(E3276 and possibly others) script by Janhouse (Janis Jansons).

No device found at /dev/ttyUSB0 (Try specifying it in --device=
argument)

In my case, the modem seems to be mounted on /dev/sr0, and I used diff to see the difference between the /dev folder when the modem isn't plugged and when it is:

$ ls /dev > temp1 # not plugged yet
$ ls /dev > temp2 # the modem is plugged
$ diff temp1 temp2
5a6
> cdrom
78a80
> sdb
79a82,83
> sg1
> sg2
82a87
> sr0

So I retried the script using the --device option:

sudo ./huawei-4g-linux.pl --device=/dev/sr0
Huawei 4g modem (E3276 and possibly others) script by Janhouse (Janis Jansons).

Opening device: /dev/sr0
Can't read serial port : Read-only file system

Some people also suggested to update the cdc_ncm.ko driver, but I don't know how to do this, is there any command to type or can I just replace the file with an updated version ?

Here are the output of lsb_release -a, uname -a, lsusb and syslog when I plug the modem:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 13.10
Release:    13.10
Codename:   saucy

$ uname -a
Linux chrubuntu 3.11.0-19-generic #33-Ubuntu SMP Tue Mar 11 18:48:34 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

$ lsusb
Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 006: ID 12d1:156a Huawei Technologies Co., Ltd. # this is the modem
Bus 002 Device 004: ID 0cf3:311e Atheros Communications, Inc. 
Bus 002 Device 003: ID 04f2:b40d Chicony Electronics Co., Ltd 
Bus 002 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

$ sudo tail -f /var/log/syslog
Apr 23 17:50:39 chrubuntu kernel: [ 2501.501218] usb 2-8: new high-speed USB device number 7 using xhci_hcd
Apr 23 17:50:39 chrubuntu kernel: [ 2501.518286] usb 2-8: New USB device found, idVendor=12d1, idProduct=156a
Apr 23 17:50:39 chrubuntu kernel: [ 2501.518296] usb 2-8: New USB device strings: Mfr=2, Product=1, SerialNumber=0
Apr 23 17:50:39 chrubuntu kernel: [ 2501.518303] usb 2-8: Product: HUAWEI Mobile
Apr 23 17:50:39 chrubuntu kernel: [ 2501.518308] usb 2-8: Manufacturer: HUAWEI Technology
Apr 23 17:50:39 chrubuntu kernel: [ 2501.560896] usb-storage 2-8:1.0: USB Mass Storage device detected
Apr 23 17:50:39 chrubuntu kernel: [ 2501.561031] scsi6 : usb-storage 2-8:1.0
Apr 23 17:50:39 chrubuntu kernel: [ 2501.561269] usb-storage 2-8:1.1: USB Mass Storage device detected
Apr 23 17:50:39 chrubuntu kernel: [ 2501.561503] scsi7 : usb-storage 2-8:1.1
Apr 23 17:50:39 chrubuntu mtp-probe: checking bus 2, device 7: "/sys/devices/pci0000:00/0000:00:14.0/usb2/2-8"
Apr 23 17:50:39 chrubuntu mtp-probe: bus: 2, device: 7 was not an MTP device
Apr 23 17:50:40 chrubuntu kernel: [ 2502.561537] scsi 6:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
Apr 23 17:50:40 chrubuntu kernel: [ 2502.561725] scsi 7:0:0:0: Direct-Access     HUAWEI   TF CARD Storage  2.31 PQ: 0 ANSI: 2
Apr 23 17:50:40 chrubuntu kernel: [ 2502.566288] sr0: scsi-1 drive
Apr 23 17:50:40 chrubuntu kernel: [ 2502.566609] sr 6:0:0:0: Attached scsi CD-ROM sr0
Apr 23 17:50:40 chrubuntu kernel: [ 2502.566763] sr 6:0:0:0: Attached scsi generic sg1 type 5
Apr 23 17:50:40 chrubuntu kernel: [ 2502.567083] sd 7:0:0:0: Attached scsi generic sg2 type 0
Apr 23 17:50:40 chrubuntu kernel: [ 2502.571026] sd 7:0:0:0: [sdb] Attached SCSI removable disk
Apr 23 17:50:40 chrubuntu kernel: [ 2502.756534] UDF-fs: INFO Mounting volume 'temp', timestamp 2013/04/10 15:41 (1000)
Apr 23 17:50:40 chrubuntu udisksd[1300]: Mounted /dev/sr0 at /media/user/temp on behalf of uid 1000

Any idea about how i could get it working ?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.