Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently moved to ubuntu 14.04. I can't compile blender afterwards. It says the error message below

CMake Error at CMakeLists.txt:2220 (message):
  Missing: "/usr/include/python3.3m/Python.h",

  Set the cache entry 'PYTHON_INCLUDE_DIR' to point to a valid python include
  path.  Containing Python.h for python version "3.3"

I went to see the /usr/include/ directory, and I only have these python-related folders: 2.7, 3.4 and 3.4m but no 3.3 or 3.3m

I tried to install the python3.3 but got this message via apt-get:

Package python3.3 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  python3.3-minimal libpython3.3-minimal libpython3.3

E: Package 'python3.3' has no installation candidate

I went on to try installing the packages listed, and it won't let me.

Before my upgrade, compiling blender worked and didn't complain of anything.

How can I get the 3.3 back?

share|improve this question
    
That's weird. In principle you already have Python3.4m... have you ever tried to include the 3.4m in the Python_include_dir? I tried to install Python3.3 but I couldn't also. –  Serfius Apr 23 at 14:17
    
Yeah, worked by replacing the missing directory with the 3.4m. However since the blender isn't fully 3.4 supported yet (Its likely so), I'm sure there's gonna be some few hitches here and there –  Rexford Apr 24 at 10:32

2 Answers 2

I fixed this by

  1. Installing the Nvidia toolkik
  2. Ran the install deps script as shown on http://wiki.blender.org/index.php/De...x/Ubuntu/CMake making sure to add the option it suggests when you run the script.
  3. used the cmake GUI took to change the python version from 3.3 to 3.4
  4. Added the flags suggested by the dependencies script
  5. configured and wrote the make files
  6. make
  7. make install
share|improve this answer

Using CMake GUI I had to change to /usr/include/python3.4 and /usr/include/python3.4m as well as python version 3.4, then compilation worked fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.