Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to Ubuntu 14.04 Norwegian letters are missing from the keyboard, there is no Norwegian keyboard to select using text entry settings (only for Dvorak, Mac etc), and when I add a new user, I cannot select Norwegian as his language - it automatically slides back to English - in other words something has gone terribly wrong with locale settings.

This is the output from the command locale:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=nb_NO.UTF-8
LANGUAGE=nb_NO:fil:en_GB:en
LC_CTYPE="nb_NO.UTF-8"
LC_NUMERIC=nb_NO.UTF-8
LC_TIME=nb_NO.UTF-8
LC_COLLATE="nb_NO.UTF-8"
LC_MONETARY=nb_NO.UTF-8
LC_MESSAGES="nb_NO.UTF-8"
LC_PAPER=nb_NO.UTF-8
LC_NAME=nb_NO.UTF-8
LC_ADDRESS=nb_NO.UTF-8
LC_TELEPHONE=nb_NO.UTF-8
LC_MEASUREMENT=nb_NO.UTF-8
LC_IDENTIFICATION=nb_NO.UTF-8
LC_ALL=
share|improve this question

1 Answer 1

I would suspect that the language Norwegian Bokmål is not installed. If so, please go to System Settings -> Language Support and install it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.