Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have bought AVer Media TV tuner H83 (aka AVerTV Volar Video Capture USB H830D)

The DVB-T function works perfectly after the driver is installed, and can be viewed and scanned with me-tv, kaffine, and used with channel.conf on VLC and smplayer. The digital over-the-air TV quality is decent.

But I can't figure out how to get analog cable working on Ubuntu. The tuner comes with a Coaxial adaptor. It can scan and watch analog cable just fine when using Windows. While that's great, I don't want to use Windows.

I have tried w_scan -ft -c TW (i am in Taiwan). I am not sure if I used it right, but I got the message below:

DVB aerial
VSB US/CA, DVB-T TW
frontend_type DVB-T, channellist 1
output format vdr-1.6
Info: using DVB adapter auto detection.
    /dev/dvb/adapter0/frontend0 -> DVB-T "AF9033 DVB-T Frontend": good :-)
Using DVB-T frontend (adapter /dev/dvb/adapter0/frontend0)
-_-_-_-_ Getting frontend capabilities-_-_-_-_
Using DVB API 5.1
frontend AF9033 DVB-T Frontend supports
INVERSION_AUTO
QAM_AUTO
TRANSMISSION_MODE_AUTO
GUARD_INTERVAL_AUTO
HIERARCHY_AUTO
FEC_AUTO
-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
Scanning 6MHz frequencies...
57000: (time: 00:04)
63000: (time: 00:06)
69000: (time: 00:09)
79000: (time: 00:11)
85000: (time: 00:14)
177000: (time: 00:16)
...
803000: (time: 02:51)

ERROR: Sorry - i couldn't get any working frequency/transponder
 Nothing to scan!!

Am I using the w_scan wrong for my purpose? I have also tried tvtime, but also didn't work. This is the error message I get for using tvtime:

Running tvtime 1.0.2.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /home/myid/.tvtime/tvtime.xml
xvoutput: No XVIDEO port found which supports YUY2 images.

*** tvtime requires hardware YUY2 overlay support from your video card
*** driver.  If you are using an older NVIDIA card (TNT2), then
*** this capability is only available with their binary drivers.
*** For some ATI cards, this feature may be found in the experimental
*** GATOS drivers: http://gatos.souceforge.net/
*** If unsure, please check with your distribution to see if your
*** X driver supports hardware overlay surfaces.

I have a notebook with ATI radeon display card inside. What am I doing wrong? Please help me get rid of Windows. Thanks!

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Give a try to TVTime, which may help you to find aerial broadcast signals and with a few options you will be able to make your tvtuner work perfectly with analog signals, the same as cable or digital (digitals not tested by me and may require special hardware).

You can install tvtime via synaptic or by dropping the next in a terminal.

sudo apt-get install tvtime

Here is a few screenshots of TVTime in action.

Here is the main TVTime television viewer, with the analog channel 9 playing and the menu shown (right clic for menu, left clic for OSD)

tvtime

Let's hit the Input configuration option in order to set up the video source, click again and again in order to cycle between the different video sources.

http://farm6.static.flickr.com/5224/5762146917_12f3b3cc19.jpg

Back in the main menu, et0s choose "Channel management" and you will have the next screen, on which you may find the "Scan channels for signal", this can take a while.

http://farm4.static.flickr.com/3307/5762690574_a3cee156a8.jpg

In the same section you can find the "Change frequency table", on which you can adjust where is the tuner going to gather frequencies table, this will allow you to define whether to use Cable or Broadcast systems.

http://farm4.static.flickr.com/3271/5762691258_1681607fa3.jpg

http://farm3.static.flickr.com/2132/5762692050_ddd95edf7e.jpg

Additionally, if you face sound issues or no-sound while playing the tv station, just try this in a terminal, change the 48000 value for whatever your broadcast can stand for, in certain cases 32000 is good enough but it depends on your tv tuner.

tvtime | arecord -D hw:1,0 -r 48000 -c 2 -f S16_LE | aplay -

Please inform how are you managing this issue.

Good luck!

P.S. You can face an issue when changing those values and TVTime may won't work anymore. To override the setup I suggest you to backup the contents of the .tvtime folder (hidden) which is placed inside of your home folder in order to revert whatever changes you made.

Edit:

I am using this TV tuners:

  1. PCI - Philips Semiconductors SAA7131/SAA7133/SAA7135 Video Broadcast Decoder (rev d0)
  2. USB - Hauppauge! WinTV-HVR 850 Hybrid DTV Stick
share|improve this answer
    
hi, i have given tvtime a try but ran into other issues. I have updated my original post with error messages from tvtime. please help, and thanks. –  hansioux May 27 '11 at 16:05
    
First of all let's make tvtime gather the appropiate video input, which can be an issue related to the norm or the display itself. Even when the error message is related to your GPU, and taking in consideration that your GPU may be correctly installed. (if not, please fix this issue before continuing this.) Then let's drop this command in a terminal and let's see what tvtime can do: tvtime --nowidescreen --norm=PAL --display=remotehost:0 –  Geppettvs D'Constanzo May 27 '11 at 17:32
    
tvtime should be able to show images but audio issues may appear. Please inform if you get at least the "no signal" message with blank or blue screen. Additionally, if you are in NTSC broadcast systems area, change the --norm=PAL for --norm=NTSC, also play with the value on --display=remotehost:0 and change its value or remove the parameter, depending on your tvtuner you may experience different results with certain parameters or without them. Good luck and please inform. –  Geppettvs D'Constanzo May 27 '11 at 17:34
    
It's working now, thanks a bunch! –  hansioux Jun 2 '11 at 13:23
    
I'm getting the no signal and blue screen with my Hauppauge WinTV 900H –  SimplySimon Sep 27 '13 at 15:44
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.