Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I installed or uninstalled some packages. I do not even remember what I was doing. As a result, now I can't see most of the system settings in settings window. Any idea how to solve this problem.

enter image description here

When I hover mouse over the window title, it shows 'Unknown Application name' I must have removed something, not sure what :-)

share|improve this question
I encountered the same problem after addressing problems with sound (following a suggestion to remove and reinstall alasbase and pulseaudio - this fixed my sound problem). Reinstalling ubuntu-desktop worked for me (and sound still working) – AnGus Jun 5 '14 at 0:44
Reinstalling ubuntu-desktop solved my sound problem which couldnt be helped by reinstalling alsa and pulseaudio. Thanks a lot – user294605 Jun 18 '14 at 9:17
Unity seems to have a (unjustified?) dependency on evolution; running sudo apt-get purge evolution* triggers this. To get the System Settings back without much evolution cruft, I ran sudo apt-get install unity-control-center --no-install-recommends afterwards, some evolution-related components get installed and System Settings with all of its icons is back. – Nickolai Leschov Oct 11 at 15:01

3 Answers 3

up vote 81 down vote accepted

You may have accidentally removed some packages (or some dependencies which caused the package to uninstall). In any case, you may try installing (or re installing) the package ubuntu-desktop. Correct any accidental package uninstallation by:

sudo apt-get install ubuntu-desktop
share|improve this answer
same problem here Indigo and I was just playing with sound... thx cshubhamrao – Trki Apr 29 '14 at 14:16
Also came a cross this problem wile experiencing sound problems and trying to fix them. Think it happened when I reinstalled alsa-base and pulsesound. – Thomas K Jul 10 '14 at 7:20
sudo apt-get install unity-control-center is probably all you need, not the entire ubuntu-desktop – David Underhill Aug 17 '14 at 0:36
@DavidUnderhill yes, but the OP may also have accidentally removed some more packages, installing the ubuntu-desktop is sure shot way to fix any more missing packages – cshubhamrao Aug 17 '14 at 15:42
I met this problem after I issues this command: apt-get remove --purge alsa-base pulseaudio – PhatHV May 27 at 4:03

Uninstall and then reinstall System Settings (unity-control-center) from the Ubuntu Software Center application.

Or run this command in terminal

  1. sudo apt-get remove unity-control-center
  2. sudo apt-get install unity-control-center
share|improve this answer
+1 This completely fixes the issue for me without reinstalling all the other stuff that comes with ubuntu-desktop, and is the best answer here. – Jason C Jul 7 '14 at 19:45
Did the trick for me, though line #1 said unity-control-center wasn't installed, but second line did it. I've been messing with my 14.04 Ubuntu recently, installed Cinnamon, removed some stuff, and disabled some services, etc, so no clue what cased settings appear like that, but i am pretty sure installing cinnamon played into it some how. Good answer, though -minimalistic and practical – Serg Nov 13 '14 at 6:15

If reinstalling ubuntu-desktop still doesn't cut it for you, you may access system settings in a wrong way. Try to open them directly from a terminal (rather than a bogus shortcut like I was):

share|improve this answer
Thank you for those using the gnome-desktop like me. Just couldn't remember the name for what needed to be removed and reinstalled. – Terrance May 26 at 16:26

protected by Community Jun 18 '14 at 10:14

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.