Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 14.04 using WUBI and after installation when it booted it showed an error:

Serious errors were found while checking the disk drive for /. 

There were three options:

press [I] to ignore, press [S] to skip mounting and press [M] to mount manually. 

After I pressed I, it showed /tmp could not be mounted and my Ubuntu isn't booting.

  • Can anybody please guide me to how to solve this problem and thanks in advance
share|improve this question
    
@pandya I have aleeady seen the link but the answers dont seem to help me to solve the problen –  user272877 Apr 23 at 9:59
    
I would like to install via wubi because then I can remove ubuntu whenever I want without any trouble. Can you please guide me to how to solve this problem –  user272877 Apr 23 at 11:14
    
I used the above and it works great. However, when I try to edit the GRUB2 boot entry; it will revert back to the original (even after saving it). I used the command: sudo gedit /etc/grub.d/10_lupin I was able to edit it and save it (changed ro to rw). But after rebooting, it reverts back to the original boot entry. How can I make it permanent? Many thanks, –  Donald May 2 at 19:29
    
holy cow, why is this even happening? –  Dirk Aug 10 at 11:12
    

1 Answer 1

up vote 19 down vote accepted
  1. In Windows Boot Manager, select Ubuntu.
  2. Press any key and enter GNU Grub2 menu.
  3. You can press "e" to edit GRUB2 boot entry.

You need to change the GRUB2 boot entry from "ro" to "rw",

e.g.

linux   /boot/vmlinuz-3.13.0-24-generic root=UUID=AAC884AC1F144321 loop=/ubuntu/disks/root.disk ro   quiet splash $vt_handoff

to

linux   /boot/vmlinuz-3.13.0-24-generic root=UUID=AAC884AC1F144321 loop=/ubuntu/disks/root.disk rw   quiet splash $vt_handoff

Press F10, you can boot in Ubuntu 14.04.

and you can fix GRUB2 boot entry:

sudo vi /etc/grub.d/10_lupin

Change the line:

linux   ${rel_dirname}/${basename} root=${LINUX_HOST_DEVICE} loop=${loop_file_relative} ro ${args}

to:

linux   ${rel_dirname}/${basename} root=${LINUX_HOST_DEVICE} loop=${loop_file_relative} rw ${args}

Regenerate GRUB2 boot entry:

sudo update-grub
share|improve this answer
    
Ok thanks for helping but last question how can I change the grub file without booting into ubuntu because I cant boot into my ubuntu –  user272877 Apr 25 at 13:21
    
1. in windows boot manager, select Ubuntu . 2. press any key and go in GUN Grub2 menu. 3. you can press "e" to edit the commands before booting. –  user273948 Apr 25 at 17:29
    
After you select "Ubuntu" from the Windows boot manager, keep Shift pressed and the Grub menu should appear. –  gfour Apr 27 at 9:10
    
Thank you very much my ubuntu finally booted! Thanks to everyone –  user272877 Apr 29 at 18:01
    
I fix the issue with this answer, but now when i restart or shutdown the computer, after selecting ubuntu in boot options, the screen go black and never initiate. I reboot manually and then select ubuntu in boot options, in the menu press e and then F10 and it loads fine, always have to press e -> F10 in order to be able to load ubuntu. Any suggestions? –  duverj May 5 at 21:38

protected by Community May 2 at 21:43

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.