Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed VLC Media Player in a fresh install of Lubuntu 14.04 LTS Trusty Tahr, meaning that my installation uses the new Linux kernel 3.13. I have installed VLC Media Player using Synaptic, which uses the official Ubuntu repositories. VLC Media Player works fine, until I attempt to use a skin. I go into VLC Media Player's settings and choose the skin file like I am supposed to. I restart VLC Media Player, but something interesting happens. It shows in the taskbar as if it is opening, but the GUI doesn't load. Then within one second, VLC Media Player disappears from the taskbar, as if it closed itself or crashed. Sometimes when this happens, I get a window that says "Lubuntu 14.04 has experienced an internal error." Then it asks me to send the bug report, which I usually do, but that doesn't have anything to do with VLC Media Player. My question is: What is wrong? Is this a bug? Have I done something wrong? (I don't think so though, because I had no problem using skins in Lubuntu 13.10 Saucy Salamander.) What can I do to fix this?

share|improve this question
Resolved by sefaustun in this post – ed0 Apr 24 '14 at 12:53
up vote 2 down vote accepted

My wife had a similar problem after upgrading Lubuntu to 14.04 on her laptop. Under Lubuntu 13.10, she had all the skins (available for download from VLC's website) to choose from and changed skins frequently. I have no idea which skin was being used when Lubuntu was upgraded, but interestingly, the VLC icon that flashed on LXPanel for a moment was the "santa-hatted" one from Christmas. Subsequent times my wife tried again to start VLC from a desktop shortcut (5 different shortcuts to playlists we'd set up for her months ago) and got nothing. VLC wouldn't start.

There is probably a faster or easier solution for this/these problem(s); but the following is what I did to fix VLC back up to the way it was for her before:

  1. To work with the files as root (as PCManFM no longer includes the option in a drop-down), go to Menu --> Accessories --> LXTerminal (or Ctrl+T) and type: gksu pcmanfm
  2. Provide your password, then go to View --> Show Hidden (or Ctrl+H) Double-click the .config folder, select (single-click) the vlc folder inside, hit Shift+Del and confirm (Enter or click the "Yes" button) you want to permanently delete the vlc folder.
  3. Click the back icon "<" and double-click the .local folder, then double-click the share folder inside and select (single-click) the vlc folder inside, hit Shift+Del and Enter
  4. View files (change from Places) as Directory Tree, navigate to /usr/share, select (single-click) that vlc folder, hit Shift+Del and Enter
  5. "X" out of PCManFM and back in LXTerminal, type: sudo apt-get remove vlc
  6. Leave everything else it suggests that you also remove and just remove the one vlc package. As soon as it is done removing VLC, type: sudo apt-get update && sudo apt-get install vlc
  7. "X" out of LXTerminal and go to (your default) Web Browser, type in and click the "here" hyperlink where you see "Download all the skins at once here (37MiB)."
  8. Click the radio button to Save File and Enter (or click the "Okay" button).
  9. Go to File Manager (PCManFM), double-click the Downloads folder, right-click (F12) and choose "Extract Here" from the drop-down menu. Scroll down to find the (probably still-selected) file and hit Shift+Del and Enter to delete it.
  10. Click one of the skins, then hit Ctrl+A to select all, right-click (F12) one of them and choose "Cut" from the drop-down menu.
  11. Click the back icon "<" and double-click the .local folder, double-click the share folder inside and double-click the vlc folder in that. Right-click (F12) in an empty space, choose "Create New... --> Folder" and name it skins2
  12. Double-click to enter the skins2 folder you just made, right-click (F12) an empty space and choose "Paste" from the drop-down menu.
  13. Right-click (F12) one of the skins and choose "Copy Path(s)" from the drop-down menu.
  14. Go to Menu --> Sound & Video --> VLC media player
  15. Go to Tools --> Preferences (or Ctrl+P) and under Interface Settings, Look & Feel; select the radio button for "Use custom skin."
  16. Click in the "Skin resource file" text box and right-click (F12) or Ctrl+V to paste. Enter, or click the "Save" button.
  17. Go to Media --> Quit (or Ctrl+Q). Go back to Menu --> Sound & Video --> VLC media player

The skin you copied the path to should be on VLC now (and changeable) and whatever files, playlists and/or shortcuts you had set up before to work with VLC should work again as well.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.