Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having some problems trying to run my Windows XP virtual machine after upgrading to Ubuntu 14.04 today. When I tried to start it a message dialog was displayed saying that the kernel drivers aren't installed, in concrete they should be provided by a packaged named virtualbox-dkms. I decided to reinstall virtualbox so dependencies will get auto resolved, but the execution of command (sudo apt-get install --reinstall virtualbox) resulted in a message similar to: "cannot reinstall package because the package cannot be downloaded" (I'm reproducing the message by memory).

Then I tried using synaptic package manager gui. The package virtualbox and its dependencies are there, but without version number or description. Then I switched to main servers, and tried to update, now the package isn't even there anymore.

It may be a problem with my sources.list file but also may be that for some reason I don't know they decide to remove virtualbox from repository.

I think I will try to download the packages from the virtual box site for now but in Ubuntu I always installed virtualbox from repository.

share|improve this question

5 Answers 5

up vote 74 down vote accepted

In Ubuntu 14.04, Virtualbox package version 4.3.10 is available in multiverse repository. So enable multiverse repository and install virtualbox through apt-get.

sudo add-apt-repository multiverse
sudo apt-get update
sudo apt-get install virtualbox

How i know that information?

$ apt-cache policy virtualbox
virtualbox:
  Installed: (none)
  Candidate: 4.3.10-dfsg-1
  Version table:
     4.3.10-dfsg-1 0
        500 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu/ trusty/multiverse amd64 Package
share|improve this answer
3  
Great, It was exactly that. I have virtualbox running again. –  Hatoru Hansou Apr 22 at 18:59
19  
Kudos for adding the "How I know that information?"-part –  MadMike Apr 30 at 11:37

It seems the problem is that VirtualBox is not entirely free software anymore. Because of this, it was moved from universe (unsupported free software) to multiverse (unsupported non-free software).

From Ubuntu bug #1164654:

Please move the virtualbox package from universe to multiverse in raring.
SInce virtualbox 4.2 building the BIOS image requires a non-free compiler (Open Watcom).
Upstream provides pre-built BIOS images which is used instead.
share|improve this answer

I was able to install it just now with the command: sudo apt-get install virtualbox. It just took about 3 minutes and it is done.

share|improve this answer

Another suggestion: install package directly from Oracle. When I open VBox under 12.04.4, I get a prompt, ". . . new version of VirtualBox has been released! Version 4.3.10 is available . . ." with a link to download from Oracle. (I don't do this, fearing I'll upset what works, as in, "if it works, don't fix it.")

share|improve this answer
1  
Welcome to Askubuntu! Isn't your suggestion the same as what the original poster mentions in his last paragraph? –  Jos Apr 29 at 21:45

I have just added VirtualBox 4.3.10 from the Ubuntu Software Centre as normal on my laptop, it was missing just after Ubuntu 14.04 LTS was released but is there now. I did also download it from the Oracle site for my desktop (where I use it most) and had to use the info for installing on Ubuntu 13.10 (which worked OK) when Ubuntu 14.04 LTS was released.

I think it may just have been delayed until after the release date. Both installations work OK.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.