Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I don't know why but

show Desktop Ctrl-Alt-D suddenly stopped working for Firefox only (in all workspaces).

Any ideas what might have caused this?

Thank you all!

ps: alt-space-n or ctrl-alt-arrow_key both continue to function normally (as a quick and effective work-around).

pps: in keyconfig I can't see any addon using this combination; plus, I did not install a new addon recently...

share|improve this question

For me, Super ("Windows") + D works.

share|improve this answer
I'm on a Thinkpad (X41); hence, there's no Windows key, and no super key (by default) either. – nutty about natty May 26 '11 at 19:24

Isn't it Super+D? To Show Desktop Ctrl+Alt+D is never a Default shortcut in Ubuntu. However if you have changed it just go to 'Keyboard Shortcuts' which you will find under 'Themes and Tweaks'

share|improve this answer
Ctrl-Alt-D does work for all applications except for Firefox (this behaviour started 2-3 days ago). – nutty about natty May 26 '11 at 19:26
I assume that adding a 2nd shortcut to "show desktop" would also work for Firefox. But the thing is: I don't want an extra individual shortcut. The two work-arounds cited above (alt-space-n or ctrl-alt-arrow_key) work already. I just don't know why FF is playing up. Could some extension suddenly have usurped that keyboard shortcut combination? But if so, which?!? – nutty about natty May 26 '11 at 19:29
up vote 0 down vote accepted

not solved, after all (problem re-appeared).

Thought yesterday's update (of Firefox and the firefox-globalmenu (unity appmenu integration for FF)) had resolved it. The firefox-globalmenu (unity appmenu integration for FF) was the only thing which I changed recently in FF, so I thought that probably was the cause of the malfunction.

So now, in the same session, suddenly (after some switching between workstations) the problem reappeared.


share|improve this answer
now it works again (same "session", not even interrupted by a standby). I don't know what changed. – nutty about natty May 28 '11 at 21:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.