Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was running Ubuntu 12.04 LTS for 64 bit systems on a dual boot custom computer with Windows 7. It was functioning normally for at least 3 days before I noticed that Youtube videos were flickering on my screen in Chromium. My first thought was to update flash, and since flash comes with the latest version of chrome, I tried updating my Chromium installation. At first I tried using the Chromium Updater Extension, but it didn't solve the problem. It was somewhere around this time that Chromium stopped opening completely. I then tried uninstalling and reinstalling Chromium, but it still wouldn't open. I tried running the program from the command line, but got a message involving "libudev.so.0" being missing from the operating system. I believe after this I had to leave so I shut down the computer.

The next day, I tried loading the Ubuntu installation, only to see that it was stuck on the purple screen. After waiting a while, I tried restarting it and loading it again. This time, it only booted to a black screen with a blinking line at the top left of the screen, much like a terminal window. I tried removing all the non essential USB devices but it still wouldn't boot.

I did attempt to use the Boot-Repair Graphical Tool, but it said that it encoutered an error and gave me this link: http://paste.ubuntu.com/7306456/ . Ubuntu still won't boot at this point, and I'd rather not have to reinstall it a third time. I did try Repairing Grub2 via the live CD terminal as accoridng to this page: https://help.ubuntu.com/community/Grub2/Installing#via_the_LiveCD_terminal , but i'm a bit nervous about removing the Grub entirely. Won't that make it difficult for me to boot windows? Also, I can't remember exactly when but I got that same message about libudev.so.0 being missing again at some point when trying to boot. Probably after using Boot-Repair.

April 23 - I did try enabling boot messages to see if anything useful came up, and I got two messages at the very end that looked important.

ureadahead main process (312) terminated with status 5 mountall main process (319) terminated with status 127

I did try looking up solutions, but the ones I found sounded very sketchy and all over the place.

share|improve this question

1 Answer 1

After some work, I managed to get the desktop back by following the directions here:

'mount: error while loading shared libraries: libudev.so.0 : no such file or directory' error while booting

At first they didn't work, so I tried copying the files in manually with little success. After trying the directions again, however, it went smoothly. Perhaps I had to activate write mode first? At any rate, it's fixed now and that link definitely helped.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.