Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a HP Pavilion-15-n004tx laptop. It supports UEFI. However when i installed Windows 8 on it, i disabled the UEFI and installed the Windows in Legacy BIOS mode. I wanted to dual boot it with Ubuntu 13.10. I read the Instructions from this link.

Now when i tried the live USB then in 'Try Ubuntu without installing' mode , i got the error saying that 'Your system is running in low graphics'. I tried Troubleshooting the problem after reading many questions from this site. They implied that i had to first install the Ubuntu and then open it in Recovery mode.

So when i tried Installing Ubuntu, everything worked fine and Ubuntu 13.10 was successfully installed on my system but when i rebooted the computer then i didn't get any GRUB menu and Windows 8 started automatically. So i made live USB of BOOT-REPAIR and ran it. But it didn't solve the problem as instead of GRUB menu, Windows 8 started automatically like before. How can i get the GRUB menu to select between Windows and Ubuntu.

I am attaching the boot-info summary given by Boot-Repair. Additionally i am uploading the result of 'msinfo32' command in Windows. I am also uploading the Screen obtained while installation of Ubuntu at 'Something Else'.

I would be really obliged to anyone who can help me solve this problem. Thanks in advance.

PS: I am unable to attach Photos so i am providing the links . Thanks!

The link for Boot Info Summary is : Boot Info Log

share|improve this question
    
post your boot-repair log link. –  Avinash Raj Apr 22 at 13:31
    
The link for msinfo32 is : oi57.tinypic.com/bveh0.jpg –  Harsh Rawat Apr 22 at 13:36
    
@AvinashRaj Hi, I have posted the link above. –  Harsh Rawat Apr 22 at 13:45
    
The link for 'Something Else' photo is : oi62.tinypic.com/suu644.jpg –  Harsh Rawat Apr 22 at 13:47
    
did you select recommended repair option in boot-repair? –  Avinash Raj Apr 22 at 14:04

1 Answer 1

Try to install grub on your / partition by running these commands on terminal(Ubuntu live disk),

sudo mount /dev/sda7 /mnt
sudo grub-install --root-directory=/mnt /dev/sda

It will install grub on your root /dev/sda7 partition.

share|improve this answer
    
There was an error message : "/usr/sbin/grub-bios-setup:warning: This LMD has no Embedding Partition;embedding won't be possible. Embedding is not possible.GRUB can only be installed in this setup by using blocklists.However blocklists are unreliable and their use is discouraged. will not proceed with blocklists " –  Harsh Rawat Apr 22 at 15:58
    
post that error message. –  Avinash Raj Apr 22 at 15:59
    
I have edited the above comment to include the error message. Thanks! –  Harsh Rawat Apr 22 at 16:07
    
    
I couldn't understand much there as i am currently a rookie. However will this problem be solved if i reinstalled the Windows 8 in UEFI environment and then tried to reinstall Ubuntu ? Also will all my data on other partitions be lost if i reinstall the windows in UEFI ? –  Harsh Rawat Apr 22 at 16:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.