Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed a test machine with Ubuntu LTS 14.04 and I went to configure the XDMCP access and found that the file /etc/lightdm/lightdm.conf is not there anymore.

In Google I found that now it is in /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf and there I modified the settings to enable XDMCP and some others:

[SeatDefaults]
user-session=ubuntu
greeter-show-manual-login=true

[XDMCPServer]
enabled=true

[SeatDefaults]
xserver-allow-tcp=true

But when I try to log in using Xming from a windows machine, I can enter the username and password but afterwards no desktop appears, only the background from the login screen.

share|improve this question

1 Answer 1

I created this file /etc/lightm/lightdm.conf:

[SeatDefaults]
xserver-allow-tcp=true
xserver-share=true
xdmcp-port=177
greeter-show-remote-login=true

[XDMCPServer]
enabled=true
port=177

Then I installed gnome-session-flashback because Unity doesn't work in the XDMCP client.

share|improve this answer
    
I did the same in a new installation but I am still getting the same window with the background and no desktop. postimg.org/image/3zwog18jd –  user272444 May 2 at 10:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.