Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Dell Studio 15 with ATI mobility HD 4500 Series graphics card.

In Ubuntu 10.10 I used the FLGRX driver which I installed from the Additional Drivers program, I need this because the open source driver runs my computer dangerously hot.

In 11.04 FGLRX is not available in the Additional Drivers program.

Why is FGLRX not showing in Additional Drivers and how do I install it?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Maybe because they are not installed? I have these drivers in Additional Driver application.

You can just install fglrx package using some package manager or just type in console:

sudo apt-get install fglrx

If you want use the newest version of these driver you have to also add PPA repository:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
share|improve this answer
    
I installed fglrx but it's still not showing in additional drivers. –  trampster May 27 '11 at 0:13
    
@trampster It is hard to say for me why you don't see them. But maybe these drivers are installed and worked. You check your Xorg.0.log file: cat /var/log/Xorg.0.log | grep fglrx –  Lukasz Stelmach May 27 '11 at 16:48
    
If your drivers are not loaded you have to change xorg.conf. you can use such command sudo aticonfig --initial to create a new xorg.conf version. –  Lukasz Stelmach May 27 '11 at 16:59
sudo apt-get remove fglrx 

then for newest ati driver:

wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-11-x86.x86_64.run

If you have a 64 bit system, then install this before anything:

sudo apt-get install ia32-libs

Once dowloaded right-click the .run file and set it to run as executable.

then.

cd /path_of_the_file       

This is for 32 bit only:

sh ./ati-driver-installer-11-11-x86.x86_64.run

This is for 64 bit only:

sh ./ati-driver-installer-11-11-x86.x86_64.run --buildpkg Ubuntu/natty

sudo dpkg -i fglrx*.deb

Once it's done.

  sudo aticonfig --initial -f

that's all you have to do.

Alternatively you can add this ppa.

   sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
   sudo apt-get update
   sudo apt-get install fglrx
share|improve this answer

I was in exactly the same situation, having a radeon hd 3450 card, in 12.04. After a normal x.org update (possibly from the backports repository?), suddenly the fglrx driver appeared in jockey, and I was able to install it successfully.

share|improve this answer
    
-1. This is a comment and doesn't answer the original question. Please delete or edit with an actionable response to answer the question –  Stephen Myall Jul 23 '12 at 19:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.