Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to use Banshee to copy files from to my Creative Zen Stone MP3 player it keeps converting the files from MP3 to FLAC.

It detects the player fine and copies files to it fine. Syncs to a playlist fine. But the only option I have under "Device Properties" is FLAC. There is no MP3 option for encoding. So instead of just copying the files it encodes them from MP3 to FLAC and then copies the FLAC files.

I have the Gstreamer multiverse ugly package installed from Synaptic already and MP# files play fine (most of my collection is MP3)

Is there something I am missing, a package I need to install that will let me sync MP3 files to my MP3 player as MP3's?

I already have ubuntu-restricted-extras installed

share|improve this question
2  
You can probably fix this with .is_audio_player, as @jnv mentioned below, but if you do that, remember to also report this as a bug so that other people with the same media player won't have to use the same workaround. banshee.fm/contribute/file-bugs –  michaelms Jun 12 '11 at 17:35
    
It already has been reported as a Banshee bug...that is not being worked on atm: bugzilla.gnome.org/show_bug.cgi?id=576722 –  HDave Dec 31 '12 at 18:38

2 Answers 2

up vote 4 down vote accepted
+50

Make sure you have package gstreamer0.10-plugins-ugly-multiverse installed - it depends on libmp3lame0 which is a basic requirement for encoding MP3 files.

If you have this package installed, you could try to create .is_audio_player file in the root directory of your MP3 player (assuming it uses USB mass storage, not MTP) - there you can specify supported audio formats, e.g.:

output_formats=audio/mpeg,audio/x-ms-wma

for MP3 and WMA. (There's some info on .is_audio_player in Rhythmbox FAQ, Banshee follows these options).

Also, you could try Rhythmbox for transfering the music just to see, whether the problem is Banshee specific or global (e.g. bad system specs for your MP3 player).

share|improve this answer
    
.is_audio_player was the missing ingredient. Thanks! –  Ash G Jun 13 '11 at 1:37

This is just a guess but try installing the package ubuntu-restricted-extras. It should contain all libraries needed for converting everything into everything.

share|improve this answer
    
Its already installed, still can't do it. –  Ash G Jun 8 '11 at 10:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.